Bug 837386 - katello configure fails on thumbslug failure to start; java.lang.UnsatisfiedLinkError
katello configure fails on thumbslug failure to start; java.lang.UnsatisfiedL...
Status: CLOSED WONTFIX
Product: Subscription Asset Manager
Classification: Red Hat
Component: thumbslug (Show other bugs)
1.2
Unspecified Unspecified
urgent Severity urgent
: rc
: 1.2
Assigned To: Bryan Kearney
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 12:38 EDT by Eric Sammons
Modified: 2017-06-26 16:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-26 16:37:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: automate_bug+


Attachments (Terms of Use)

  None (edit)
Description Eric Sammons 2012-07-03 12:38:06 EDT
Description of problem:
During the configuration process for katello / headpin thumbslug will try to start, at this point the configuration fails due to thumbslug failing to start.


Version-Release number of selected component (if applicable):
thumbslug-0.0.24-1.fc16.noarch

Steps to Reproduce:
1. su - thumbslug -s /bin/bash -c 'java -jar /usr/share/thumbslug/thumbslug.jar'
2.
3.
  
Actual results:
Exception in thread "main" java.lang.UnsatisfiedLinkError: Can't obtain class com.sun.jna.CallbackReference.AttachOptions
	at com.sun.jna.Native.initIDs(Native Method)
	at com.sun.jna.Native.<clinit>(Native.java:116)
	at com.sun.akuma.CLibrary.<clinit>(Unknown Source)
	at com.sun.akuma.JavaVMArguments.resolvePID(Unknown Source)
	at com.sun.akuma.JavaVMArguments.ofLinux(Unknown Source)
	at com.sun.akuma.JavaVMArguments.of(Unknown Source)
	at com.sun.akuma.JavaVMArguments.current(Unknown Source)
	at com.sun.akuma.Daemon.daemonize(Unknown Source)
	at org.candlepin.thumbslug.Main.main(Main.java:127)


Expected results:
successful start up of thumbslug


Additional info:
This appears to be related to CLASSPATH ordering issue.  Starting thumbslug, thumbslug is picking up the installed jna class.
Comment 1 Chris Duryee 2012-07-03 12:41:33 EDT
This has to do with the upgrade of jna from 3.2 to 3.4 in fedora, see https://bugzilla.redhat.com/show_bug.cgi?id=833786
Comment 2 Chris Duryee 2012-07-09 17:31:31 EDT
Eric,

I have a test build, but it requires deps that used to just be build-time deps. I'd like to make sure it works ok for you before I commit, so I don't commit before you have access to all the deps.

Let me know when you are free and I can supply you with the test build.
Comment 3 Eric Sammons 2012-07-10 11:44:27 EDT
Chris,

Looks like we have a new error?


# rpm -qa thumbslug
thumbslug-0.0.24-1.git.4.df3e7a5.fc16.noarch
[root@brainslug ~]# rpm -ql thumbslug
/etc/rc.d/init.d/thumbslug
/etc/thumbslug
/etc/thumbslug/thumbslug.conf
/usr/bin/thumbslug
/usr/share/doc/thumbslug-0.0.24
/usr/share/doc/thumbslug-0.0.24/README
/usr/share/thumbslug
/usr/share/thumbslug/thumbslug.jar
/var/lock/subsys/thumbslug
/var/log/thumbslug
/var/run/thumbslug
/var/run/thumbslug/thumbslug.pid
[root@brainslug ~]# sudo su - thumbslug -s /bin/bash -c 'java -jar /usr/share/thumbslug/thumbslug.jar'
Exception in thread "main" java.lang.NoClassDefFoundError: org/jboss/netty/channel/group/ChannelGroup
Caused by: java.lang.ClassNotFoundException: org.jboss.netty.channel.group.ChannelGroup
	at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
Could not find the main class: org.candlepin.thumbslug.Main. Program will exit.
Comment 5 Chris Duryee 2012-07-10 11:52:28 EDT
Try running it with just "service thumbslug start". The old way of bypassing the init script will not work anymore.
Comment 6 Chris Duryee 2012-07-11 11:17:50 EDT
75e749bc master 0.25+
Comment 7 Eric Sammons 2012-07-11 13:57:39 EDT
thumbslug-0.0.25-1.fc16.noarch

# service thumbslug restart
thumbslug (via systemctl):                       [  OK  ]
#

VERIFIED
Comment 8 Bryan Kearney 2017-06-26 16:37:14 EDT
The release of Satellite 5.8 we are deprecating the support of Subscription Asset Manager. The release notes for 5.8 can be found at https://access.redhat.com/documentation/en-us/red_hat_satellite/5.8/pdf/release_notes/Red_Hat_Satellite-5.8-Release_Notes-en-US.pdf.

I am therefore closing out this bug as WONTFIX. If you believe this to be an error, please feel free tor each out to either Rich Jerrido or Bryan Kearney. Thank you!

Note You need to log in before you can comment on or make changes to this bug.