Bug 837404 - udev errors on boot when using sw raid
udev errors on boot when using sw raid
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: udev (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Aristeu Rozanski
qe-baseos-daemons
:
Depends On:
Blocks: 804141
  Show dependency treegraph
 
Reported: 2012-07-03 15:10 EDT by Ruggero Marchei
Modified: 2013-08-23 10:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-23 10:03:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vv (18.15 KB, text/plain)
2012-07-03 15:10 EDT, Ruggero Marchei
no flags Details

  None (edit)
Description Ruggero Marchei 2012-07-03 15:10:49 EDT
Created attachment 596072 [details]
lspci -vv

Description of problem:

when using /boot on a sw raid1 partition udev daemon reports some errors on boot.


Version-Release number of selected component (if applicable):
udev-147-2.42.el6.x86_64


How reproducible:
Every boot time

Steps to Reproduce:
1. from anaconda create a raid1 and put the /boot partition (ext4) on top of it
2. reboot when the installation finish
3. check the errors on every boot (they are also logged on /var/log/boot.log)
  
Actual results:
Starting udev: Gudevd-work[617]: error opening ATTR{/sys/devices/virtual/block/md0/queue/iosched/slice_idle} for writing: No such file or directory

udevd-work[617]: error opening ATTR{/sys/devices/virtual/block/md0/queue/iosched/quantum} for writing: No such file or directory

Expected results:
boot without error messages

Additional info:

I have 2 RAID partitions: 
RAID0 (md0): 4 disks (2 spares) -> /boot
RAID10 (md1): 4 disks (0 spares) -> LVM pv with 1 vg and 2 lv (/ and swap)

the errors appear only for md0
Comment 2 Harald Hoyer 2012-07-05 10:16:49 EDT
what is the output of:

# grep -r slice_idle /{lib,etc}/udev/rules.d/
# grep -r quantum /{lib,etc}/udev/rules.d/
Comment 3 Ruggero Marchei 2012-07-05 11:20:28 EDT
# grep -r slice_idle /{lib,etc}/udev/rules.d/
/lib/udev/rules.d/80-iosched.rules:ATTR{queue/iosched/slice_idle}="0"

# grep -r quantum /{lib,etc}/udev/rules.d/
/lib/udev/rules.d/80-iosched.rules:ATTR{queue/iosched/quantum}="32"
Comment 4 Harald Hoyer 2012-07-06 04:17:51 EDT
(In reply to comment #3)
> # grep -r slice_idle /{lib,etc}/udev/rules.d/
> /lib/udev/rules.d/80-iosched.rules:ATTR{queue/iosched/slice_idle}="0"
> 
> # grep -r quantum /{lib,etc}/udev/rules.d/
> /lib/udev/rules.d/80-iosched.rules:ATTR{queue/iosched/quantum}="32"

What's the output of:

# rpm -qf /lib/udev/rules.d/80-iosched.rules
Comment 5 Ruggero Marchei 2012-07-06 11:36:34 EDT
# rpm -qf /lib/udev/rules.d/80-iosched.rules
udev-147-2.42.el6.x86_64
Comment 7 Aristeu Rozanski 2012-11-26 14:56:45 EST
Hi Ruggero,
what's the kernel version you're using?
Comment 8 Ruggero Marchei 2012-11-27 06:09:32 EST
(In reply to comment #7)
> Hi Ruggero,
> what's the kernel version you're using?

Hi Aristeu,
I'm currently using the kernel 2.6.32-279.14.1.el6.x86_64
Comment 9 Aristeu Rozanski 2012-11-28 16:07:20 EST
*** Bug 879219 has been marked as a duplicate of this bug. ***
Comment 10 Aristeu Rozanski 2012-11-28 16:09:03 EST
hm for some reason this:
KERNEL=="dm-*", GOTO="end_iosched"

isn't working and on 879219,

ATTR{queue/scheduler}!="*\[cfq\]", GOTO="end_iosched"

isn't working either
Comment 11 Aristeu Rozanski 2013-01-07 15:43:12 EST
Not being able to reproduce it here. Ruggero, do you mind attaching the dmesg,
/var/log/boot.log with /etc/udev/udev.conf with udev_log="info"?
Comment 12 Ruggero Marchei 2013-02-02 05:44:03 EST
I just noticed that I don't have this error anymore. I think it disappeared with some update, but udev is still at the same version (udev-147-2.42.el6.x86_64). 
I have 2 VMs (but they are CentOS) with the same FS layout that are not up to date and where the problem still persist. I going to update them to check if it solves the problem and which package fixes it.
Comment 13 IBM Bug Proxy 2013-02-22 11:30:59 EST
------- Comment From tarak.reddy@in.ibm.com 2013-02-22 16:27 EDT-------
I could able see this problem but it seems to be a race. I tried 5times online and offline and could able to see error messages one time.

[root@r3544008 ~]# cat /etc/issue
Red Hat Enterprise Linux Server release 6.4 (Santiago)
Kernel \r on an \m

[root@r3544008 ~]# uname -a
Linux r3544008 2.6.32-358.el6.s390x #1 SMP Tue Jan 29 12:06:31 EST 2013 s390x s390x s390x GNU/Linux
[root@r3544008 ~]#

Feb 22 17:21:28 r3544008 kernel: dasd-eckd 0.0.6275: New DASD 3390/0C (CU 3990/01) with 10017 cylinders, 15 heads, 224 sectors
Feb 22 17:21:28 r3544008 kernel: dasd-eckd 0.0.6275: DASD with 4 KB/block, 7212240 KB total size, 48 KB/track, compatible disk layout
Feb 22 17:21:28 r3544008 kernel: dasdc:VOL1/  0X6275: dasdc1

Feb 22 17:21:38 r3544008 udevd-work[3918]: error opening ATTR{/sys/devices/css0/0.0.0003/0.0.6275/block/dasdc/queue/iosched/slice_idle} for writing: No such file or directory
Feb 22 17:21:38 r3544008 udevd-work[3918]: error opening ATTR{/sys/devices/css0/0.0.0003/0.0.6275/block/dasdc/queue/iosched/quantum} for writing: No such file or directory
Comment 15 Aristeu Rozanski 2013-03-18 13:54:54 EDT
(In reply to comment #13)
> ------- Comment From tarak.reddy@in.ibm.com 2013-02-22 16:27 EDT-------
> I could able see this problem but it seems to be a race. I tried 5times
> online and offline and could able to see error messages one time.
> 
> [root@r3544008 ~]# cat /etc/issue
> Red Hat Enterprise Linux Server release 6.4 (Santiago)
> Kernel \r on an \m
> 
> [root@r3544008 ~]# uname -a
> Linux r3544008 2.6.32-358.el6.s390x #1 SMP Tue Jan 29 12:06:31 EST 2013
> s390x s390x s390x GNU/Linux
> [root@r3544008 ~]#
> 
> Feb 22 17:21:28 r3544008 kernel: dasd-eckd 0.0.6275: New DASD 3390/0C (CU
> 3990/01) with 10017 cylinders, 15 heads, 224 sectors
> Feb 22 17:21:28 r3544008 kernel: dasd-eckd 0.0.6275: DASD with 4 KB/block,
> 7212240 KB total size, 48 KB/track, compatible disk layout
> Feb 22 17:21:28 r3544008 kernel: dasdc:VOL1/  0X6275: dasdc1
> 
> Feb 22 17:21:38 r3544008 udevd-work[3918]: error opening
> ATTR{/sys/devices/css0/0.0.0003/0.0.6275/block/dasdc/queue/iosched/
> slice_idle} for writing: No such file or directory
> Feb 22 17:21:38 r3544008 udevd-work[3918]: error opening
> ATTR{/sys/devices/css0/0.0.0003/0.0.6275/block/dasdc/queue/iosched/quantum}
> for writing: No such file or directory

did you give a try in the test rules from BZ 879219:
https://bugzilla.redhat.com/attachment.cgi?id=674328
Comment 16 IBM Bug Proxy 2013-08-23 07:40:34 EDT
------- Comment From hannsj_uhl@de.ibm.com 2013-08-23 11:32 EDT-------
Hello Red Hat,
using the GA kernel of RHEL6.4 we could not reproduce this bugzilla ...
... there this bugzilla is closed at the IBM side.
Thanks for all your support on this bugzilla.
Comment 17 Aristeu Rozanski 2013-08-23 10:04:08 EDT
Reported fixed in 6.4.

Note You need to log in before you can comment on or make changes to this bug.