Bug 837424 - Typeless gears migration broke repo symlink
Typeless gears migration broke repo symlink
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Ram Ranganathan
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 16:23 EDT by Ram Ranganathan
Modified: 2015-05-14 18:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 19:43:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ram Ranganathan 2012-07-03 16:23:47 EDT
Description of problem:
As part of the typeless gears migration, we did not create an app-root/repo 
symlink to runtime/repo and it breaks existing apps with cron jobs. 
New apps are fine.

Version-Release number of selected component (if applicable):
All

How reproducible:
Always

Steps to Reproduce:
1.  Create an app (with old devenv prior to typeless gears)
2.  Run migration
3.
  
Actual results:
There should be an app-root/repo symlink that points to runtime/repo/

Expected results:
Missing symlink.

Additional info:
Comment 1 Ram Ranganathan 2012-07-03 16:25:30 EDT
This is an issue w/ migration on prod -- fixing it w/ the migration script. 
Fixed in git commit 19d731dd1e0bc761a8f54cf1385ff154989d2a17.
Comment 2 Xiaoli Tian 2012-07-04 04:40:07 EDT
Testing is blocked by bug 837522
Comment 3 Jianwei Hou 2012-07-06 05:36:45 EDT
verified on devenv-stage_221

because our latest rhc-admin-migrate does not support version 2.0.12 or 2.0.13, we verified this issue in the following way:

1.create an app on old instance
2.ssh into app and remove symbolic link app-root/repo 
[root@ip-10-114-34-181 app-root]# rm repo
rm: remove symbolic link `repo'? y
[root@ip-10-114-34-181 app-root]# ls
data  runtime
3.run migration
4.verify the symbolic link app-root/repo is created again and points to rutime/repo
[root@ip-10-114-34-181 app-root]# ll
total 8
drwxr-x---. 2 683b9846a8944f8d853c5878a29629ac 683b9846a8944f8d853c5878a29629ac 4096 Jul  6 05:26 data
lrwxrwxrwx. 1 683b9846a8944f8d853c5878a29629ac 683b9846a8944f8d853c5878a29629ac   12 Jul  6 05:26 repo -> runtime/repo
drwxr-x---. 3 683b9846a8944f8d853c5878a29629ac 683b9846a8944f8d853c5878a29629ac 4096 Jul  6 05:26 runtime

Note You need to log in before you can comment on or make changes to this bug.