Bug 837477 - Find Project Version failed to find all the relative project version
Find Project Version failed to find all the relative project version
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.7
Unspecified Unspecified
unspecified Severity medium
: ---
: 1.7
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 00:24 EDT by Ding-Yi Chen
Modified: 2012-09-12 20:43 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.7-SNAPSHOT (20120708-0026)
Doc Type: Bug Fix
Doc Text:
Cause: Search in version group page only search through project id and version id, not project name. Consequence: No result return if search for project name. Fix: Implement search through project id, version id and project name. Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 01:11:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-07-04 00:24:43 EDT
Description of problem:

Find Project Version failed to find all project-versions whose project names contain the search string.

Version-Release number of selected component (if applicable):
Zanata version 1.7-SNAPSHOT (20120704-0026)

How reproducible:
Always


Steps to Reproduce:
1. Sign in our master nukes server. 
2. Search "RHEL" in project search.
   You should see a list of project name that contains "RHEL"
3. Click Groups
4. Create a new group called "EL"
5. Click "EL" -> "Add project versions"
6. Search "RHEL"
  
Actual results:
None is returned.

Expected results:
Projects listed in step 2 should be shown.

Additional info:
When I searched "rhel" (lower case), it behaved as expected.
Their project IDs do contain "rhel", however.
Comment 1 Sean Flanigan 2012-07-04 00:39:18 EDT
We should add a note to the search page that it only searches slugs (IDs), not project/version names.

And it should probably not be case-sensitive.
Comment 2 Alex Eng 2012-07-04 00:56:12 EDT
Fixed search problem. 
New search: case insensitive
Search through: Project slug, project name, version slug

See 
https://github.com/zanata/zanata/commit/8a96d98b918b588cf6e5729be4664d619552f30c
https://github.com/zanata/zanata/commit/93dc850985aba8174c58a93bceaf153e4c89f7ed
Comment 3 Ding-Yi Chen 2012-07-08 22:11:36 EDT
(In reply to comment #1)
> We should add a note to the search page that it only searches slugs (IDs),
> not project/version names.
> 
> And it should probably not be case-sensitive.

I still think it is a bug if we search only the slugs without display them in project list.

Anyway, since Alex already fixed the bug. I can verify it.
VERIFIED with 1.7-SNAPSHOT (20120708-0026)

Note You need to log in before you can comment on or make changes to this bug.