Bug 837552 - reserve workflow can't list all available distro for a RHEL Family like before
reserve workflow can't list all available distro for a RHEL Family like before
Status: CLOSED WONTFIX
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.9
All Linux
urgent Severity medium (vote)
: ---
: ---
Assigned To: Raymond Mancy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 04:39 EDT by yanfu,wang
Modified: 2014-12-07 20:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-04 23:17:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (153.79 KB, image/png)
2012-07-04 04:39 EDT, yanfu,wang
no flags Details

  None (edit)
Description yanfu,wang 2012-07-04 04:39:53 EDT
Created attachment 596171 [details]
screenshot

Description of problem:
reserve workflow from web UI can't list all available distro for a RHEL Family like before, and just list the newest distro.


Steps to Reproduce:
For example, click reserve from 'Scheduler' menu. 
Select Family "RedHatEnterpriseLinuxServer5"
Select Tag "None Selected" or none select tag
Distro will be selected to "RHEL5.9-Server-20120704.0.n" automatically, and I can't select others like 'RHEL5.9-Server-20120628.0.n'.
I will attach the PrtScreen page.
  
Actual results:
Just the newest distro "RHEL5.9-Server-20120704.0.n" give users.

Expected results:
Users want to select different or older, but available distro like before.
For example, RHEL5.9-Server-20120628.0.n, RHEL5.9-Server-20120629.0.n

Additional info:
Comment 1 Raymond Mancy 2012-07-04 17:31:45 EDT
That's very odd. I can't replicate this.

Those fields are now in a form so it should show the args in the url, but on your printscreen it does not. What happens if you switch try another tag and then go back to 'None Selected'. Do you have any JS errors? What version of FF do you have?
Comment 2 yanfu,wang 2012-07-04 22:27:41 EDT
(In reply to comment #1)
> That's very odd. I can't replicate this.
> 
> Those fields are now in a form so it should show the args in the url, but on
> your printscreen it does not. What happens if you switch try another tag and
> then go back to 'None Selected'. Do you have any JS errors? What version of
> FF do you have?

It doesn't work if I switch another tag and then go back to 'None Selected'.
No JS errors shown too.
From my colleague screen, the 'Distro' drop-down box should be selected different distros, but it's grey and disable select in my page. So just one distro shown to me which impact my testing work.
My environment shown as below:
$ rpm -qa|grep firefox
firefox-3.5.6-1.fc12.i686
$ uname -a
Linux dhcp-65-195.nay.redhat.com 2.6.31.9-174.fc12.i686.PAE #1 SMP Mon Dec 21 06:04:56 UTC 2009 i686 i686 i386 GNU/Linux
Comment 3 Raymond Mancy 2012-07-04 23:17:54 EDT
For that feature to work it requires Geckon 2.0 (>= Firefox 4).
I'm afraid you'll have to upgrade your browser for this to work correctly.
Comment 4 Raymond Mancy 2012-07-04 23:18:22 EDT
I of course meant 'Gecko'...
Comment 5 yanfu,wang 2012-07-05 02:25:51 EDT
(In reply to comment #3)
> For that feature to work it requires Geckon 2.0 (>= Firefox 4).
> I'm afraid you'll have to upgrade your browser for this to work correctly.

The problem is solved after I update to firefox4, and I hope 'Note' or 'Important' item needing attention could be noted in somewhere when beaker update in the future.
Thank you for your help timely, Raymond.

Note You need to log in before you can comment on or make changes to this bug.