Bug 837555 - RFE: clients to show server version as well as API version
RFE: clients to show server version as well as API version
Status: CLOSED WONTFIX
Product: Zanata
Classification: Community
Component: Component-PythonClient, Component-Logic, Component-Maven (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Runa Bhattacharjee
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 04:50 EDT by Parag Nemade
Modified: 2013-03-03 21:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 23:00:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2012-07-04 04:50:27 EDT
Description of problem:
I see zanata server deployed is 1.6.1 version whereas zanata push/pull shows
zanata python client version: 1.3.7, zanata server API version: 1.6.0

Why is there  difference in zanata server version?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Mason 2012-07-04 23:05:25 EDT
The server version and API version can change independently. Version 1.6.1 of the server uses version 1.6.0 of the client.

I recommend showing both server and API versions in the output to make it clear that these are two different things.

e.g. the output above would be changed to:-
zanata python client version: 1.3.7, zanata server version: 1.6.1, zanata API version: 1.6.0
Comment 2 David Mason 2012-07-04 23:07:06 EDT
First paragraph above should end "version 1.6.0 of the API"
Comment 3 Parag Nemade 2012-08-06 09:57:30 EDT
What is a need to select 3 different components for this bug?
Comment 4 Parag Nemade 2012-08-09 11:12:54 EDT
Can some one please review why this bug is against 3 components? This un-necessarily making component field fatter, thus my bug tracker list becomes last field summary hyphenated.
Comment 5 Parag Nemade 2012-08-09 11:20:37 EDT
and date field is completely invisible and I need to use horizontal scroll :-(
Comment 6 Sean Flanigan 2012-08-09 19:40:37 EDT
It's on three components because work will be required on both clients and on the server.

Why do you consider this RFE to be urgent?
Comment 7 Parag Nemade 2012-08-09 23:52:16 EDT
I have already explained what problem I am facing. This is not at all urgent to me. Urgency is because someone to check this and select a correct single component. 

Wish I was not the owner of this bug. I would have removed myself immediately as its causing visibility issue for my bug tracker.

Anyway I have been forcefully rearranged my bug tracker fields.

resetting severity and priority.
Comment 8 Parag Nemade 2012-09-19 03:47:07 EDT
Any progress on this ***three component*** bug?
Comment 9 Sean Flanigan 2012-09-20 23:00:52 EDT
This feature isn't planned on the roadmap.
Comment 10 Parag Nemade 2012-09-20 23:03:16 EDT
Thanks for closing this. Lets hope the confusion continues for the end user.

Note You need to log in before you can comment on or make changes to this bug.