Bug 837606 - firefox has no x-scheme-handler/http mime
firefox has no x-scheme-handler/http mime
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firefox (Show other bugs)
All Linux
medium Severity medium
: beta
: 7.0
Assigned To: Martin Stransky
Desktop QE
: Reopened
: 848879 (view as bug list)
Depends On:
Blocks: 852154
  Show dependency treegraph
Reported: 2012-07-04 07:30 EDT by Vladimir Benes
Modified: 2013-04-19 05:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-04-19 05:06:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
screenshot (65.75 KB, image/png)
2012-07-04 07:32 EDT, Vladimir Benes
no flags Details
3.6.0 screenshot (28.50 KB, image/png)
2012-10-16 05:05 EDT, Vladimir Benes
no flags Details

  None (edit)
Description Vladimir Benes 2012-07-04 07:30:09 EDT
Description of problem:
I cannot get Firefox/Konqueror as a default application via details in control-center.. it's greyed out.. see picture

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.go into control-center
2.go into details
3.try to change from firefox to konqueror or vice versa
Actual results:
drop down menu is greyed out.. nothing in it

Expected results:
should be either firefox or konqueror if both are installed

Additional info:
don't know if some package is not missing in my installation as it was just minimal with X and some GNOME apps
Comment 1 Vladimir Benes 2012-07-04 07:32:55 EDT
Created attachment 596195 [details]
Comment 3 Matthias Clasen 2012-10-12 11:04:34 EDT
*** Bug 848879 has been marked as a duplicate of this bug. ***
Comment 4 Bastien Nocera 2012-10-15 12:04:47 EDT
Looks like Konqueror or Firefox aren't exporting that they handle the x-scheme-handler/http mime-type. Can you reproduce the bug with GNOME 3.6-based setup?
Comment 5 Vladimir Benes 2012-10-16 05:05:03 EDT
(In reply to comment #4)
> Looks like Konqueror or Firefox aren't exporting that they handle the
> x-scheme-handler/http mime-type. Can you reproduce the bug with GNOME
> 3.6-based setup?

yes, see screenshot attached

version used:
Comment 6 Vladimir Benes 2012-10-16 05:05:38 EDT
Created attachment 628050 [details]
3.6.0 screenshot
Comment 7 Bastien Nocera 2012-10-16 08:19:11 EDT
What's the output of:
gvfs-mime --query x-scheme-handler/http
on your system?
Comment 8 Vladimir Benes 2012-10-16 08:49:46 EDT
No default applications for 'x-scheme-handler/http'
Comment 9 Matthias Clasen 2012-10-16 09:07:25 EDT
firefox-16.0.1-1.fc18.x86_64 does claim to support x-scheme-handler/http, and it does show up in the control-center combo box here. Whats different in rhel7 ?
Comment 10 Vladimir Benes 2012-10-16 09:31:34 EDT
$ rpm -q firefox
Comment 11 Matthias Clasen 2012-10-16 10:16:36 EDT
So, I assume this will sort itself out when we get the next esr with firefox 17.

Vladimir, can you file a separate bug against konqueror for adding x-scheme-handler/http ?
Comment 13 Bastien Nocera 2012-10-16 11:46:38 EDT
Can we close this as NOTABUG or reassign it to Firefox?
Comment 16 Radek Bíba 2013-03-06 07:22:48 EST
Firefox and Konqueror are available on my system, but only Konqueror is in the menu. Additionally, when I click a link in a non-KDE application, a Konqueror window is opened, but the home page is displayed instead of the desired URL. Steps to reproduce: run yelp, scroll down to About, click it, click the link to the license.
Comment 17 Martin Stransky 2013-03-14 10:55:10 EDT
Added to firefox-17.0.4-2.el7
Comment 18 Martin Stransky 2013-03-19 03:10:18 EDT
Built in brew, will be a part of next compose.
Comment 20 Vladimir Benes 2013-03-19 04:37:09 EDT
it now works as expected ;-)

Note You need to log in before you can comment on or make changes to this bug.