Bug 837611 - Unwanted keyboard layout change
Unwanted keyboard layout change
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 07:44 EDT by Daniel
Modified: 2012-07-05 05:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-04 23:52:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel 2012-07-04 07:44:04 EDT
Description of problem:
I am using a Japanese keyboard and when I switch to ibus-table-wubi or ibus-pinyin, the keyboard layout will change to "en".
Also, ibus added a input method named "English - English(US)" for me and I cannot delete it.

Version-Release number of selected component (if applicable):
$ rpm -qa | grep "^ibus"
ibus-libs-1.4.99.20120428-2.fc17.x86_64
ibus-pinyin-1.4.0-16.fc17.x86_64
ibus-pinyin-db-open-phrase-1.4.0-16.fc17.noarch
ibus-table-chinese-1.3.5-2.fc17.noarch
ibus-gtk2-1.4.99.20120428-2.fc17.x86_64
ibus-anthy-1.4.99.20120327-1.fc17.x86_64
ibus-gnome3-1.4.99.20120428-2.fc17.x86_64
ibus-gtk3-1.4.99.20120428-2.fc17.x86_64
ibus-table-chinese-wubi-haifeng-1.3.5-2.fc17.noarch
ibus-table-1.3.9.20110827-2.fc17.noarch
ibus-devel-1.4.99.20120428-2.fc17.x86_64
ibus-mozc-1.5.1090.102-2.fc17.x86_64
ibus-1.4.99.20120428-2.fc17.x86_64
ibus-table-chinese-wubi-jidian-1.3.5-2.fc17.noarch

How reproducible:
100%

Steps to Reproduce:
1. login to the computer
2. activate ibus-table-wubi or ibus-pinyin
3. an icon for selecting keyboard layout displays on the right corner and the default value is "en" instead of "ja".
  
Actual results:
The keyboard layout changed to "en"

Expected results:
The keyboard layout should be the system's default layout

Additional info:
Comment 1 fujiwara 2012-07-04 23:52:08 EDT
(In reply to comment #0)
> Description of problem:
> I am using a Japanese keyboard and when I switch to ibus-table-wubi or
> ibus-pinyin, the keyboard layout will change to "en".

I think ibus-pinyin and ibus-table-wubi are expected to use 'us' keyboard.
You could modify the configuration at your own risk in $HOME/.cache/ibus/bus/registry.xml and replace 'us' with 'jp' but probably I think no support.

         <component>
             <name>org.freedesktop.IBus.Pinyin</name>
             <description>Pinyin Component</description>
 ...
             <engines>
                    <engine>
                         <name>pinyin</name>
                         <longname>Pinyin</longname>
                         <description>Pinyin input method</description>
                         <language>zh_CN</language>
 ...
-                        <layout>us</layout>
+                        <layout>jp</layout>
                     </engine>
         </component>
Comment 2 Daniel 2012-07-05 01:02:07 EDT
This bug began from Fedora 17.
I can use ibus-pinyin and ibus-table-wubi with system's default(japanese) keyboard layout without any problems in Fedora 11~16.
I also reported this bug to ibus' project homepage and the author said this is fedora's bug.
Comment 3 fujiwara 2012-07-05 02:17:06 EDT
I know it.
ibus is changed between 16 and 17.
ibus 17 uses libgnomekbd (libxklavier) to work with the configuration in gnome-control-center.
So if the engine needs 'us' layout, the 'us' layout will be added in XKB and ibus detects it as a keyboard engine.
The implementation is required since currently both ibus and gnome-settings-daemon handles XKB.

We have the plan to migrate ibus and gnome-settings-daemon in f18 so your problem might be enhanced in f18. But it's the design in f17.
Comment 4 Daniel 2012-07-05 05:00:36 EDT
fujiwara-san,

Thank you very much for your response.
I will try to change my setting file and see if it will work for me.
Also, I am looking forward to f18.

Note You need to log in before you can comment on or make changes to this bug.