Bug 837640 - hierarchical collectors invalidating ads
hierarchical collectors invalidating ads
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
2.2
Unspecified Unspecified
medium Severity medium
: 2.2
: ---
Assigned To: Matthew Farrellee
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 10:23 EDT by Lubos Trilety
Modified: 2013-01-04 10:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-05 17:14:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubos Trilety 2012-07-04 10:23:09 EDT
Description of problem:
After stopping machine with sub collector the daemons are still present in master collector statistics.

Version-Release number of selected component (if applicable):
condor-7.6.5-0.14

How reproducible:
100%

Steps to Reproduce:
1. Set sub collector on remote machine
COLLECTOR0: $(COLLECTOR)
COLLECTOR0_ARGS = -f -p 12345
COLLECTOR0_ENVIRONMENT = "_CONDOR_COLLECTOR_LOG=$(LOG)/CollectorLog"
DAEMON_LIST = MASTER, STARTD, COLLECTOR0
CONDOR_HOST = <master.collector.machine>
STARTD.COLLECTOR_HOST = <sub.collector.machine>:12345
CONDOR_VIEW_HOST = $(COLLECTOR_HOST)

2. check running daemons using 'condor_status -any'
# condor_status -any
MyType               TargetType           Name                          
Collector            None                 Personal Condor at <sub.collector.machine>
Machine              Job                  <sub.collector.machine>
Machine              Job                  <sub.collector.machine>
DaemonMaster         None                 <sub.collector.machine>
Negotiator           None                 <master.collector.machine>
Collector            None                 Personal Condor at <master.collector.machine>
...

3. stop condor on machine with sub collector, check the daemons again
# condor_status -any
MyType               TargetType           Name                          
Collector            None                 Personal Condor at <sub.collector.machine>
Machine              Job                  <sub.collector.machine>
Machine              Job                  <sub.collector.machine>
Negotiator           None                 <master.collector.machine>
Collector            None                 Personal Condor at <master.collector.machine>
...
  
Actual results:
Only ads from directly connected daemons were removed, DaemonMaster in this case. Sub collector and daemons connected to it are still present. They are removed after 15 minutes.

Expected results:
All daemons should be removed immediately after stopping condor on machine with sub collector.

Additional info:
Comment 1 Matthew Farrellee 2012-07-05 17:14:06 EDT
FYI, Version should likely be 1.0.

This is by design.

Consider, TOP-Collector <- { SUB-Collector-A, SUB-Collector-B } <- startd. Shutdown of SUB-Collector-A should not erase knowledge of startd from TOP-Collector.

Note You need to log in before you can comment on or make changes to this bug.