Bug 837676 - glusterfs-server-3.3.0 glustershd.log is filling up with self heal messages that fail
glusterfs-server-3.3.0 glustershd.log is filling up with self heal messages t...
Status: CLOSED DUPLICATE of bug 844804
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: vsomyaju
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 13:07 EDT by Jorge Silva
Modified: 2015-03-04 19:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-24 06:24:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jorge Silva 2012-07-04 13:07:31 EDT
Description of problem: log file for glustershd.log is continually growing these entries are repeated with different gfids :
I [afr-common.c:1215:afr_detect_self_heal_by_lookup_status] 0-homes-replicate-0: entries are missing in lookup of <gfid:22d16acd-044f-46be-a943-53b7aa91f7d5>.
[2012-07-04 12:56:42.962089] I [afr-common.c:1340:afr_launch_self_heal] 0-homes-replicate-0: background  meta-data data entry missing-entry gfid self-heal triggered. path: <gfid:22d16acd-044f-46be-a943-53b7aa91f7d5>, reason: lookup detected pending operations
[2012-07-04 12:56:42.962907] W [client3_1-fops.c:1495:client3_1_inodelk_cbk] 0-homes-client-1: remote operation failed: No such file or directory
[2012-07-04 12:56:42.963217] E [afr-self-heal-metadata.c:539:afr_sh_metadata_post_nonblocking_inodelk_cbk] 0-homes-replicate-0: Non Blocking metadata inodelks failed for <gfid:22d16acd-044f-46be-a943-53b7aa91f7d5>.
[2012-07-04 12:56:42.963264] E [afr-self-heal-metadata.c:541:afr_sh_metadata_post_nonblocking_inodelk_cbk] 0-homes-replicate-0: Metadata self-heal failed for <gfid:22d16acd-044f-46be-a943-53b7aa91f7d5>.
[2012-07-04 12:56:42.963935] W [client3_1-fops.c:418:client3_1_open_cbk] 0-homes-client-1: remote operation failed: No such file or directory. Path: <gfid:22d16acd-044f-46be-a943-53b7aa91f7d5> (00000000-0000-0000-0000-000000000000)
[2012-07-04 12:56:42.963978] E [afr-self-heal-data.c:1314:afr_sh_data_open_cbk] 0-homes-replicate-0: open of <gfid:22d16acd-044f-46be-a943-53b7aa91f7d5> failed on child homes-client-1 (No such file or directory)
[2012-07-04 12:56:42.963991] E [afr-self-heal-common.c:2156:afr_self_heal_completion_cbk] 0-homes-replicate-0: background  meta-data data entry self-heal failed on <gfid:22d16acd-044f-46be-a943-53b7aa91f7d5>



Version-Release number of selected component (if applicable):
glusterfs-server-3.3.0-1.el6.x86_64
Linux 2.6.32-220.17.1.el6.x86_64 #1 SMP Wed May 16 00:01:37 BST 2012 x86_64 x86_64 x86_64 GNU/Linux
Centos 6.2

How reproducible:
Stop glusterd , clear log file and restart

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
Either 

Additional info: Gluster volume config
Volume Name: homes
Type: Replicate
Volume ID: xxxxxxxx-2906-4faf-818f-75388b3d0c54
Status: Started
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Bricks:
Brick1: server1:/gluster/homes
Brick2: server1:/gluster/homes
Options Reconfigured:
performance.cache-size: 512MB
nfs.disable: on
performance.cache-refresh-timeout: 5
performance.io-thread-count: 32
performance.io-cache: on
Comment 1 vsomyaju 2012-09-24 06:24:00 EDT

*** This bug has been marked as a duplicate of bug 844804 ***

Note You need to log in before you can comment on or make changes to this bug.