Bug 837677 - KDE4 login crashes
KDE4 login crashes
Status: CLOSED DUPLICATE of bug 751891
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 13:16 EDT by Juan
Modified: 2012-07-08 17:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-08 17:38:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan 2012-07-04 13:16:10 EDT
Description of problem:

Imposible to open a session in KDE4.

Version-Release number of selected component (if applicable):

$ rpm -qa |grep kde
kdelibs-4.8.4-5.fc16.x86_64
kdesdk-common-4.8.4-1.fc16.noarch
xsettings-kde-0.12.3-3.fc16.x86_64
laughlin-backgrounds-kde-14.1.0-3.fc15.noarch
kde-runtime-4.8.4-2.fc16.x86_64
kdenetwork-common-4.8.4-1.fc16.noarch
kdepimlibs-4.8.4-1.fc16.x86_64
kde-settings-ksplash-4.7-14.fc16.noarch
laughlin-kde-theme-14.0.0-3.fc15.noarch
kde-baseapps-libs-4.8.4-1.fc16.x86_64
lockdev-1.0.3-10.fc16.i686
verne-kde-theme-15.91.0-1.fc16.noarch
kdeartwork-sounds-4.8.4-1.fc16.noarch
kdemultimedia-common-4.8.4-3.fc16.noarch
leonidas-kde-theme-11.0.3-2.fc15.noarch
lockdev-1.0.3-10.fc16.x86_64
kde-l10n-4.8.4-1.fc16.noarch
kde-runtime-libs-4.8.4-2.fc16.x86_64
kde-workspace-4.8.4-2.fc16.x86_64
kdegraphics-strigi-analyzer-4.8.4-1.fc16.x86_64
kde-l10n-Catalan-4.8.4-1.fc16.noarch
constantine-backgrounds-kde-12.1.1-4.fc15.noarch
unixODBC-kde-2.2.14-13.fc15.i686
kde-settings-plasma-4.7-14.fc16.noarch
verne-backgrounds-kde-15.92.1-1.fc16.noarch
kde-baseapps-4.8.4-1.fc16.x86_64
unixODBC-kde-2.2.14-13.fc15.x86_64
kdelibs-common-4.8.4-5.fc16.x86_64
kde-wallpapers-4.8.4-1.fc16.noarch
laughlin-backgrounds-extras-kde-14.1.0-3.fc15.noarch
constantine-kde-theme-12.1.0-3.fc15.noarch
kdepimlibs-akonadi-4.8.4-1.fc16.x86_64
kdelibs3-3.5.10-31.fc16.x86_64
lockdev-devel-1.0.3-10.fc16.x86_64
kde-runtime-flags-4.8.4-2.fc16.noarch
kde-workspace-libs-4.8.4-2.fc16.x86_64
kdeutils-common-4.8.4-1.fc16.noarch
solar-kde-theme-0.1.19-2.fc15.noarch
kde-settings-4.7-14.fc16.noarch
kde-filesystem-4-38.fc15.x86_64
polkit-kde-0.99.0-3.fc16.x86_64
kde-l10n-Spanish-4.8.4-1.fc16.noarch


How reproducible:

Upgrading to KDE 4.8.4 from previous version

 
Additional info:

extract from /var/log/messages

Jul  3 13:12:48 AMD64x2 kernel: [ 1009.809359] kded4[2180]: segfault at 42fe0c28b8 ip 000000370120a0cc sp 00007fff86966ef0 error 4 in ld-2.14.90.so[3701200000+22000]
Jul  3 13:12:54 AMD64x2 kernel: [ 1016.041890] drkonqi[2181]: segfault at 41833c25d8 ip 000000370120a0cc sp 00007ffff4b21630 error 4 in ld-2.14.90.so[3701200000+22000]
Jul  3 13:12:55 AMD64x2 kernel: [ 1016.995479] ksmserver[2186]: segfault at 41833c25d8 ip 000000370120a0cc sp 00007fff93fea2d0 error 4 in ld-2.14.90.so[3701200000+22000]
Jul  3 13:12:57 AMD64x2 systemd-logind[1054]: Removed session 2.
Jul  3 13:13:08 AMD64x2 systemd-logind[1054]: New session 3 of user juan.
Jul  3 13:13:08 AMD64x2 systemd-logind[1054]: Linked /tmp/.X11-unix/X0 to /run/user/juan/X11-display.
Jul  3 13:13:10 AMD64x2 kernel: [ 1031.842758] drkonqi[2453]: segfault at 41833c25d8 ip 000000370120a0cc sp 00007fffd61d0ff0 error 4 in ld-2.14.90.so[3701200000+22000]
Jul  3 13:13:10 AMD64x2 kernel: [ 1032.072106] ksmserver[2456]: segfault at 41833c25d8 ip 000000370120a0cc sp 00007fff4eff3e90 error 4 in ld-2.14.90.so[3701200000+22000]
Jul  3 13:13:10 AMD64x2 kernel: [ 1032.099931] kded4[2452]: segfault at 42fe0c28b8 ip 000000370120a0cc sp 00007fff561e2940 error 4 in ld-2.14.90.so[3701200000+22000]
Jul  3 13:13:10 AMD64x2 systemd-logind[1054]: Removed session 3.

...

Jul  4 17:12:24 AMD64x2 kernel: [ 1501.375542] drkonqi[3032]: segfault at 401d45a8b4 ip 000000370120a0cc sp 00007fffa5508ea0 err
or 4 in ld-2.14.90.so[3701200000+22000]
Jul  4 17:12:24 AMD64x2 kernel: [ 1501.890528] kded4[3033]: segfault at 42fe0c28b8 ip 000000370120a0cc sp 00007fff074914e0 error
 4 in ld-2.14.90.so[3701200000+22000]
Jul  4 17:12:24 AMD64x2 kernel: [ 1502.038278] ksmserver[3040]: segfault at 42fe0c28b8 ip 000000370120a0cc sp 00007fff561bc6d0 error 4 in ld-2.14.90.so[3701200000+22000]
Jul  4 17:12:24 AMD64x2 systemd-logind[1047]: Removed session 10.
Comment 1 Kevin Kofler 2012-07-04 19:28:28 EDT
NVidia driver bug. See the original report and its several duplicates for details.

*** This bug has been marked as a duplicate of bug 751891 ***
Comment 2 Juan 2012-07-05 06:58:25 EDT
(In reply to comment #1)
> NVidia driver bug. See the original report and its several duplicates for
> details.
> 
> *** This bug has been marked as a duplicate of bug 751891 ***

Hi Kevin,

I'm sorry so much for disapointing you, but your quick diagnostic it seems not to be the solution, because:

1.- I was not using the proprietary driver
2.- Now I have installed, and throubleshooted, the proprietary nvidia driver to make it work, but the problem persists and I'm only able to work with GNOME.

$ rpm -qa |grep nvidia
akmod-nvidia-295.59-1.fc16.x86_64
nvidia-settings-1.0-17.fc16.x86_64
xorg-x11-drv-nvidia-295.59-1.fc16.x86_64
nvidia-xconfig-1.0-15.fc16.x86_64
xorg-x11-drv-nvidia-libs-295.59-1.fc16.x86_64
kmod-nvidia-3.4.2-1.fc16.x86_64-295.59-1.fc16.x86_64


If I've installed the proprietary driver is because several years ago KDE didn't work with the free one... but after several months I was forced again to use the free driver, due to the continuous and serious problems with the proprietary one.

I like Red Hat/Fedora, I've been using it since 90's. But I like much more KDE...

These are the last entries on my log about KDE:

Jul  5 12:34:55 AMD64x2 kernel: [ 1778.704182] drkonqi[3602]: segfault at 401d45a8b4 ip 000000370120a0cc sp 00007fff91546180 error 4 in ld-2.14.90.so[3701200000+22000]
Jul  5 12:34:55 AMD64x2 kernel: [ 1778.960053] ksmserver[3607]: segfault at 42fe0c28b8 ip 000000370120a0cc sp 00007fffffdea470 error 4 in ld-2.14.90.so[3701200000+22000]
Jul  5 12:34:55 AMD64x2 systemd-logind[1015]: Removed session 13.
Comment 3 Juan 2012-07-05 07:11:24 EDT
I forgot to mention that I've uninstalled KDE prior to install the proprietary driver and I've reinstalled it after the "fixed" proprietary driver works...
Comment 4 Kevin Kofler 2012-07-05 08:17:11 EDT
If you had the proprietary driver (in particular, its libGL) installed, even if you were not actually running the kernel space parts, that's enough to trigger the bug.

I need a full backtrace to be 100% sure, but the crash being in ld.so, I strongly suspect that it really is bug #751891.

You should try to uninstall the proprietary driver COMPLETELY, in particular, to make sure you are using the stock Fedora version of libGL.
Comment 5 Juan 2012-07-05 10:18:12 EDT
OK, I'll try to remove the proprietary driver and install again the nouveau driver.

Tell me what kind of debug you need and I'll try to answer in a couple of days... I've spent so much time with this issue and I have a lot of work to do.

Regards
Comment 6 Rex Dieter 2012-07-05 10:27:45 EDT
We would need a backtrace (with debuginfo), whether than be from a manual gdb, abrt, or drkonqi doesn't matter.
Comment 7 Juan 2012-07-07 06:58:08 EDT
(In reply to comment #6)
> We would need a backtrace (with debuginfo), whether than be from a manual
> gdb, abrt, or drkonqi doesn't matter.

Hi again,

I've made a backtrace of ksmserver with proprietary driver installed, then I've deinstalled it and installed nouveau driver and made again the backtrace after rebooting.

These are the results:

[juan@AMD64x2 ~]$ rpm -qa |grep nvidia
nvidia-settings-1.0-17.fc16.x86_64
nvidia-xconfig-1.0-15.fc16.x86_64
[juan@AMD64x2 ~]$ rpm -qa |grep nouveau
xorg-x11-drv-nouveau-0.0.16-27.20110720gitb806e3f.fc16.x86_64
[juan@AMD64x2 ~]$ su
Contraseña: 
[root@AMD64x2 juan]# cd
[root@AMD64x2 ~]# more bt-proprietary.txt 

Reading symbols from /usr/bin/ksmserver...(no debugging symbols found)...done.
Missing separate debuginfos, use: debuginfo-install kde-workspace-4.8.4-2.fc16.x86_64
(gdb) run
Starting program: /usr/bin/ksmserver

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7de50cc in do_lookup_x () from /lib64/ld-linux-x86-64.so.2
(gdb) bt
#0  0x00007ffff7de50cc in do_lookup_x () from /lib64/ld-linux-x86-64.so.2
#1  0x00007ffff7de5413 in _dl_lookup_symbol_x ()
   from /lib64/ld-linux-x86-64.so.2
#2  0x00007ffff7de6eb5 in _dl_relocate_object ()
   from /lib64/ld-linux-x86-64.so.2
#3  0x00007ffff7ddeb2e in dl_main () from /lib64/ld-linux-x86-64.so.2
#4  0x00007ffff7df07f4 in _dl_sysdep_start () from /lib64/ld-linux-x86-64.so.2
#5  0x00007ffff7de0415 in _dl_start () from /lib64/ld-linux-x86-64.so.2
#6  0x00007ffff7ddc6e8 in _start () from /lib64/ld-linux-x86-64.so.2
#7  0x0000000000000001 in ?? ()
#8  0x00007fffffffe6ae in ?? ()
#9  0x0000000000000000 in ?? ()
[root@AMD64x2 ~]# more bt-nouveau.txt 
Reading symbols from /usr/bin/ksmserver...(no debugging symbols found)...done.
Missing separate debuginfos, use: debuginfo-install kde-workspace-4.8.4-2.fc16.x86_64
(gdb) run
Starting program: /usr/bin/ksmserver

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7de50cc in do_lookup_x () from /lib64/ld-linux-x86-64.so.2
(gdb) bt
#0  0x00007ffff7de50cc in do_lookup_x () from /lib64/ld-linux-x86-64.so.2
#1  0x00007ffff7de5413 in _dl_lookup_symbol_x ()
   from /lib64/ld-linux-x86-64.so.2
#2  0x00007ffff7de6eb5 in _dl_relocate_object ()
   from /lib64/ld-linux-x86-64.so.2
#3  0x00007ffff7ddeb2e in dl_main () from /lib64/ld-linux-x86-64.so.2
#4  0x00007ffff7df07f4 in _dl_sysdep_start () from /lib64/ld-linux-x86-64.so.2
#5  0x00007ffff7de0415 in _dl_start () from /lib64/ld-linux-x86-64.so.2
#6  0x00007ffff7ddc6e8 in _start () from /lib64/ld-linux-x86-64.so.2
#7  0x0000000000000001 in ?? ()
#8  0x00007fffffffe660 in ?? ()
#9  0x0000000000000000 in ?? ()
[root@AMD64x2 ~]#
Comment 8 Rex Dieter 2012-07-07 09:49:40 EDT
missing debuginfo.

And, are you *sure* no nvidia libGL library is present on your system?

Either way, workarounds for the issue include:
1.  re-rerun /etc/cron.daily/prelink after installing nvidia libGL
2.  disable prelink (set PRELINKING=no in /etc/sysconfig/prelink), and rerun /etc/cron.daily/prelink
Comment 9 Kevin Kofler 2012-07-08 05:11:15 EDT
In any case, your backtraces match bug #751891.

When uninstalling the NVidia driver, you need to completely remove all *nvidia* packages, including and especially nvidia-libGL. If you ever ran the installation script from the upstream NVidia web page, removing packages might not be enough, try their uninstaller script or just reinstall Fedora entirely.
Comment 10 Juan 2012-07-08 17:38:54 EDT
Hi,

Thank you for your support. After trying to uninstall driver without success,finally I've decided to upgrade to Fedora 17... to be caught by other bug related to dracut.

I'm begining to suspect that the latests updates and the upgrade to Fedora 17 are more buggy than previous ones :( ... in the other hand, it is an opportunity to learn the new components of the system ;)


Regards

Juan

*** This bug has been marked as a duplicate of bug 751891 ***

Note You need to log in before you can comment on or make changes to this bug.