Bug 837700 - SELinux is preventing /usr/sbin/tmpwatch from 'getattr' accesses on the file /var/tmp/kdecache-root/icon-cache.kcache.
SELinux is preventing /usr/sbin/tmpwatch from 'getattr' accesses on the file ...
Status: CLOSED DUPLICATE of bug 837478
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c86d5492d1bacbd45bebdf08695...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 17:17 EDT by perepluts
Modified: 2012-07-09 01:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 01:38:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description perepluts 2012-07-04 17:17:46 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.4-3.fc17.x86_64
time:           Thu 05 Jul 2012 03:15:46 AM EEST

description:
:SELinux is preventing /usr/sbin/tmpwatch from 'getattr' accesses on the file /var/tmp/kdecache-root/icon-cache.kcache.
:
:*****  Plugin catchall_labels (83.8 confidence) suggests  ********************
:
:If you want to allow tmpwatch to have getattr access on the icon-cache.kcache file
:Then you need to change the label on /var/tmp/kdecache-root/icon-cache.kcache
:Do
:# semanage fcontext -a -t FILE_TYPE '/var/tmp/kdecache-root/icon-cache.kcache'
:where FILE_TYPE is one of the following: abrt_helper_exec_t, amavis_spool_t, logfile, textrel_shlib_t, locale_t, etc_t, file_t, proc_t, man_t, rpm_script_tmp_t, ld_so_cache_t, abrt_var_cache_t, etc_t, cert_t, admin_home_t, sosreport_tmp_t, machineid_t, tmpfile, rpm_tmp_t, cfengine_var_log_t, sssd_public_t, abrt_var_run_t, puppet_tmp_t, user_cron_spool_t, sandbox_file_t, sysctl_crypto_t, kismet_log_t, tmpreaper_exec_t, passwd_file_t, rpm_var_cache_t, krb5_conf_t, httpd_cache_t, user_tmp_t, var_lib_t, logfile, user_home_type, cfengine_var_log_t, file_type, httpd_sys_rw_content_t, print_spool_t, samba_var_t, abrt_t, samba_etc_t, ld_so_t, lib_t, tmpreaper_t, user_home_t, net_conf_t, cpu_online_t, krb5_host_rcache_t. 
:Then execute: 
:restorecon -v '/var/tmp/kdecache-root/icon-cache.kcache'
:
:
:*****  Plugin catchall (17.1 confidence) suggests  ***************************
:
:If you believe that tmpwatch should be allowed getattr access on the icon-cache.kcache file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep tmpwatch /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:tmpreaper_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:unlabeled_t:s0
:Target Objects                /var/tmp/kdecache-root/icon-cache.kcache [ file ]
:Source                        tmpwatch
:Source Path                   /usr/sbin/tmpwatch
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           tmpwatch-2.10.3-2.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-134.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.4-3.fc17.x86_64 #1 SMP
:                              Tue Jun 26 20:54:56 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Thu 05 Jul 2012 03:14:11 AM EEST
:Last Seen                     Thu 05 Jul 2012 03:14:11 AM EEST
:Local ID                      767cae63-8b1b-4e00-b418-9e6cbcffd28f
:
:Raw Audit Messages
:type=AVC msg=audit(1341447251.771:422): avc:  denied  { getattr } for  pid=9757 comm="tmpwatch" path="/var/tmp/kdecache-root/icon-cache.kcache" dev="sdc1" ino=262952 scontext=system_u:system_r:tmpreaper_t:s0-s0:c0.c1023 tcontext=system_u:object_r:unlabeled_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1341447251.771:422): arch=x86_64 syscall=lstat success=no exit=EACCES a0=15a0883 a1=7fff16e5d100 a2=7fff16e5d100 a3=3bc15782fd items=0 ppid=9754 pid=9757 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=19 comm=tmpwatch exe=/usr/sbin/tmpwatch subj=system_u:system_r:tmpreaper_t:s0-s0:c0.c1023 key=(null)
:
:Hash: tmpwatch,tmpreaper_t,unlabeled_t,file,getattr
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-07-09 01:38:57 EDT

*** This bug has been marked as a duplicate of bug 837478 ***

Note You need to log in before you can comment on or make changes to this bug.