Bug 837820 - [abrt] fedora-review-0.1.3-1.fc17: os.py:157:makedirs:OSError: [Errno 13] Permission denied: '/var/lib/mock/fedora-rawhide-i386'
[abrt] fedora-review-0.1.3-1.fc17: os.py:157:makedirs:OSError: [Errno 13] Per...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedora-review (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
abrt_hash:9a5a4620ac8ada2b88f6601cc59...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 08:32 EDT by Paul Lange
Modified: 2012-07-05 18:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-05 18:31:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Lange 2012-07-05 08:32:06 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python -tt /usr/bin/fedora-review -b 834548
comment:        Didn't enter root password
executable:     /usr/bin/fedora-review
kernel:         3.4.4-3.fc17.i686
time:           Do 05 Jul 2012 14:31:24 CEST
uid:            1000
username:       paul

backtrace:
:os.py:157:makedirs:OSError: [Errno 13] Permission denied: '/var/lib/mock/fedora-rawhide-i386'
:
:Traceback (most recent call last):
:  File "/usr/bin/fedora-review", line 203, in <module>
:    review.run()
:  File "/usr/bin/fedora-review", line 197, in run
:    self.__do_report()
:  File "/usr/bin/fedora-review", line 111, in __do_report
:    self.__do_report_local(self.args.workdir)
:  File "/usr/bin/fedora-review", line 120, in __do_report_local
:    self.__run_checks(files_spec[0], files_srpm[0])
:  File "/usr/bin/fedora-review", line 166, in __run_checks
:    self.checks.run_checks(output=output)
:  File "/usr/lib/python2.7/site-packages/FedoraReview/misc.py", line 117, in run_checks
:    if test.is_applicable():
:  File "/usr/lib/python2.7/site-packages/FedoraReview/checks/ccpp.py", line 13, in is_applicable
:    self.sources_have_files('*.c') or \
:  File "/usr/lib/python2.7/site-packages/FedoraReview/checks/generic.py", line 90, in sources_have_files
:    sources_files = self.sources.get_files_sources()
:  File "/usr/lib/python2.7/site-packages/FedoraReview/__init__.py", line 275, in get_files_sources
:    self.extract_all()
:  File "/usr/lib/python2.7/site-packages/FedoraReview/__init__.py", line 254, in extract_all
:    source.extract()
:  File "/usr/lib/python2.7/site-packages/FedoraReview/__init__.py", line 329, in extract
:    os.makedirs(self.extract_dir)
:  File "/usr/lib/python2.7/os.py", line 150, in makedirs
:    makedirs(head, mode)
:  File "/usr/lib/python2.7/os.py", line 150, in makedirs
:    makedirs(head, mode)
:  File "/usr/lib/python2.7/os.py", line 150, in makedirs
:    makedirs(head, mode)
:  File "/usr/lib/python2.7/os.py", line 150, in makedirs
:    makedirs(head, mode)
:  File "/usr/lib/python2.7/os.py", line 150, in makedirs
:    makedirs(head, mode)
:  File "/usr/lib/python2.7/os.py", line 150, in makedirs
:    makedirs(head, mode)
:  File "/usr/lib/python2.7/os.py", line 157, in makedirs
:    mkdir(name, mode)
:OSError: [Errno 13] Permission denied: '/var/lib/mock/fedora-rawhide-i386'
:
:Local variables in innermost frame:
:tail: 'fedora-rawhide-i386'
:head: '/var/lib/mock'
:name: '/var/lib/mock/fedora-rawhide-i386'
:mode: 511
Comment 1 Pierre-YvesChibon 2012-07-05 12:24:23 EDT
Can you run a mock build without entering the root password ?
If not, then you have not added your user to the 'mock' group which explains the permission denied.

This also means that this is not a bug, please read the man page of fedora-review.

If you can run a mock build under your normal user, then, there is something else going on that we will need to debug.
Can you reproduce this bug easily ?

Thanks for reporting!
Comment 2 Paul Lange 2012-07-05 18:31:49 EDT
My account wasn't in the mock group, thanks for the fast reply!
I'm closing this now.

Note You need to log in before you can comment on or make changes to this bug.