Bug 837873 - repo delete is not deleting the contents on the file system
repo delete is not deleting the contents on the file system
Status: CLOSED NOTABUG
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.0.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pradeep Kilambi
Preethi Thomas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 12:30 EDT by Preethi Thomas
Modified: 2013-09-09 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 13:38:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-07-05 12:30:00 EDT
Description of problem:

After repo delete content still exist in the file system. 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.create and sync a repo
2.delete the repo
3.
  
Actual results:
[root@preethi-el6-pulp ~]# pulp-admin repo list
+----------------------------------------------------------------------+
                              Repositories
+----------------------------------------------------------------------+

[root@preethi-el6-pulp ~]# pulp-admin repo list
+----------------------------------------------------------------------+
                              Repositories
+----------------------------------------------------------------------+

[root@preethi-el6-pulp ~]# ls -l /var/lib/pulp/content/
total 104
drwxr-xr-x.    4 apache apache  4096 Jul  3 15:39 distribution
drwxr-xr-x. 2884 apache apache 98304 Jul  3 13:35 rpm


Expected results:


Additional info:
Comment 1 Jay Dobies 2012-07-16 13:38:27 EDT
This is the intended behavior in v2. Content is not deleted until the orphaned delete is run.

Note You need to log in before you can comment on or make changes to this bug.