Bug 837968 - Until configuration is unified include samples of both
Until configuration is unified include samples of both
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 6.1.0
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 19:23 EDT by Alan Santos
Modified: 2015-02-05 20:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Instance Name: Not Defined Build: CSProcessor Builder Version 1.4 Build Filter: null Build Name: Build Date: 15-06-2012 10:17:05
Last Closed: 2013-03-20 19:55:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Santos 2012-07-05 19:23:33 EDT
Description of problem:

Quite frequently the docs include configuration samples only for library. In all cases the equivalent should be included for server mode. If the functionality is not available in server mode this should be indicated instead.
Comment 1 Misha H. Ali 2012-07-10 02:27:38 EDT
Scouring docs for such cases and located the following:

* Configure Local/Dist/Inv/Repl Cache Mode - Same config for remote? Suspect yes, but check.

* 2.3.4.2. About Asynchronous Communications - Pretty much same as above.

* 4.5.3. Replication Queue Usage

* 6.2.3. Write-Through Caching Configuration (Library Mode) - Is there a remote config?

* 6.3.4. Unscheduled Write-Behind Strategy Configuration - Make it clearer that this is for lib mode only.

* 7.4. Explicit Pessimistic Locking Example - probably only for library, check for remote and make it clear either way.

* 7.5. Implicit Pessimistic Locking Example - same as above

* 7.6. Configure Optimistic and Pessimistic Locking - same as above

* 7.7.2. Distributed Locking Example - same as above

* 8.1.3. File Cache Store Configuration - check if lib only. if yes, add info, is no, add remote config.

* 8.2.3.2. Enable Shared Cache Loaders - is this for both modes?

* 13.2. Listener Example - Both modes?

* 15.3. Adding Custom Interceptors - different for lib and remote?

* JGroups and MBeans - usage mode agnostic?
Comment 2 Misha H. Ali 2012-07-26 19:59:54 EDT
(In reply to comment #1)
> Scouring docs for such cases and located the following:
> 
> * Configure Local/Dist/Inv/Repl Cache Mode - Same config for remote? Suspect
> yes, but check.

For local-cache, yes. Rest are not in Server.

> 
> * 2.3.4.2. About Asynchronous Communications - Pretty much same as above.

In lib mode it is set with the mode="SYNC" attribute for local-cache, replicated-cache, distributed-cache elements. In server mode, this is done the same way for local-cache.

> * 4.5.3. Replication Queue Usage

Not in remote.

> 
> * 6.2.3. Write-Through Caching Configuration (Library Mode) - Is there a
> remote config?
> 
> * 6.3.4. Unscheduled Write-Behind Strategy Configuration - Make it clearer
> that this is for lib mode only.
> 
> * 7.4. Explicit Pessimistic Locking Example - probably only for library,
> check for remote and make it clear either way.
> 
> * 7.5. Implicit Pessimistic Locking Example - same as above
> 
> * 7.6. Configure Optimistic and Pessimistic Locking - same as above
> 
> * 7.7.2. Distributed Locking Example - same as above
> 
> * 8.1.3. File Cache Store Configuration - check if lib only. if yes, add
> info, is no, add remote config.
> 
> * 8.2.3.2. Enable Shared Cache Loaders - is this for both modes?
> 
> * 13.2. Listener Example - Both modes?
> 
> * 15.3. Adding Custom Interceptors - different for lib and remote?
> 

This is for library. Cannot find anything for server.

> * JGroups and MBeans - usage mode agnostic?

JGroups looks like its is configured something like this for server:

<subsystem xmlns="urn:jboss:domain:jgroups:1.1" default-stack="${jboss.default.jgroups.stack:udp}">
  <stack name="udp">
     <transport type="UDP" socket-bindin="jgroups-udp">
   ...
     </transport>
   <protocol type="FD_SOCK" socket-binding="jgroups-udp-fd"/>
   ...
  </stack>
  ...
</subsystem>

Additionally:

<socket-binding-group name="standard sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">
    ...
   <socket-binding name="jgroups-mping" port="0" multicast-address="${jboss.default.multicast.address:234.99.54.14}" multicast-port="45700"/>
   <socket-binding name="jgroups-tcp" port="7600"/>
   <socket-binding name="jgroups-tcp-fd" port="57600"/>
   <socket-binding name="jgroups-udp" port="55200" multicast-address="${jboss.default.multicast.address:234.99.54.14}" multicast-port="45688"/>
   <socket-binding name="jgroups-udp-fd" port="54200"/>
   ...
</socket-binding-group>

> Mbeans:

Appears to be tied to JMX config. Need Tristan to point to Mbeans config.
Comment 5 Misha H. Ali 2013-02-21 02:17:06 EST
Added a bunch of configurations for lib mode. I believe now we have both usage modes configs for everything in the admin guide. \o/
Comment 6 Misha H. Ali 2013-03-20 19:55:07 EDT
Now available at https://access.redhat.com/knowledge/docs/JBoss_Data_Grid/

Note You need to log in before you can comment on or make changes to this bug.