Bug 837987 - JDG plugin pack contains unnecessary plugins
JDG plugin pack contains unnecessary plugins
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JDG (Show other bugs)
JON 3.1.0
Unspecified Unspecified
urgent Severity high
: ---
: JON 3.1.1
Assigned To: John Sanda
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 23:11 EDT by Alan Santos
Modified: 2015-02-05 20:19 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 07:02:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Santos 2012-07-05 23:11:27 EDT
Description of problem:

jdg plugin pack contains 
    0 Thu Jun 14 14:26:26 EDT 2012 jon-plugin-pack-jdg-3.1.0.GA/
 16814 Thu Jun 14 14:26:24 EDT 2012 jon-plugin-pack-jdg-3.1.0.GA/jboss-datagrid-rhq-plugin-6.0.0.GA-redhat-1.jar
 11682 Thu Jun 14 14:24:40 EDT 2012 jon-plugin-pack-jdg-3.1.0.GA/jopr-hibernate-plugin-4.4.0.JON310GA.jar
 26706 Thu Jun 14 14:24:40 EDT 2012 jon-plugin-pack-jdg-3.1.0.GA/jopr-jboss-cache-plugin-4.4.0.JON310GA.jar
 17531 Thu Jun 14 14:24:40 EDT 2012 jon-plugin-pack-jdg-3.1.0.GA/jopr-jboss-cache-v3-plugin-4.4.0.JON310GA.jar
2841776 Thu Jun 14 14:24:40 EDT 2012 jon-plugin-pack-jdg-3.1.0.GA/jopr-jboss-as-plugin-4.4.0.JON310GA.jar
 50905 Thu Jun 14 14:24:40 EDT 2012 jon-plugin-pack-jdg-3.1.0.GA/hornetq-jopr-plugin-2.0.0.Final.jar
2476711 Thu Jun 14 14:24:40 EDT 2012 jon-plugin-pack-jdg-3.1.0.GA/jopr-jboss-as-5-plugin-4.4.0.JON310GA.jar
1333038 Thu Jun 14 14:24:40 EDT 2012 jon-plugin-pack-jdg-3.1.0.GA/rhq-jboss-as-7-plugin-4.4.0.JON310GA.jar
286285 Thu Jun 14 14:24:40 EDT 2012 jon-plugin-pack-jdg-3.1.0.GA/jopr-rhq-server-plugin-4.4.0.JON310GA.jar
  1688 Thu Jun 14 14:22:58 EDT 2012 jon-plugin-pack-jdg-3.1.0.GA/README.txt
  8123 Thu Jun 14 14:22:58 EDT 2012 jon-plugin-pack-jdg-3.1.0.GA/EULA
 17987 Thu Jun 14 14:22:58 EDT 2012 jon-plugin-pack-jdg-3.1.0.GA/LICENSE



It should not have jboss cache, hornetq, as5, etc... probably just datagrid and as7?



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Sanda 2012-08-06 10:13:49 EDT
Removed all plugin dependencies except for AS 7 plugin. Changes have been pushed to the release/jon3.1.x branch.

commit hashes:
6254b7bb47e
f279d09418
Comment 2 John Sanda 2012-08-13 22:16:42 EDT
Moving to ON_QA since JON 3.1.1 ER2 build is availble - https://brewweb.devel.redhat.com/buildinfo?buildID=228250
Comment 3 Sunil Kondkar 2012-08-27 04:50:38 EDT
Verified on JON 3.1.1.ER3 build.

The JDG plugin pack contains datagrid and AS 7 plugin:

-rw-r--r--. 1 root root   17987 Aug 22 01:08 LICENSE
-rw-r--r--. 1 root root    8123 Aug 22 01:08 EULA
-rw-r--r--. 1 root root    1688 Aug 22 01:08 README.txt
-rw-rw-r--. 1 root root 1349968 Aug 22 01:10 rhq-jboss-as-7-plugin-4.4.0.JON311ER3.jar
-rw-rw-r--. 1 root root   12795 Aug 22 01:12 jboss-datagrid-rhq-plugin-6.0.1.ER2-redhat-1.jar

Note You need to log in before you can comment on or make changes to this bug.