Bug 837999 - search&replace should exclude obsolete documents
search&replace should exclude obsolete documents
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
1.6.1
Unspecified Unspecified
unspecified Severity high
: ---
: 2.0
Assigned To: Patrick Huang
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-06 01:20 EDT by Mie Yamamoto
Modified: 2013-02-25 22:46 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.0.3-SNAPSHOT (20121129-1430)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 22:46:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Runa Bhattacharjee 2012-07-30 08:15:57 EDT
Hello Mie,
I can't seem to reproduce this error. Can you please add a screenshot of this error?

Thanks
Runa
Comment 2 Michelle Kim 2012-11-06 02:26:55 EST
Hi Mie,

I am currently doing bug triage for some of the open bugs for Zanata. Will you be able to reproduce this bug in current production system? If not, are you happy to close this bug?

Thank you for your help,
Michelle
Comment 3 Mie Yamamoto 2012-11-07 17:04:17 EST
Created attachment 640411 [details]
S&R obsolete

Hi I don't know how you decide obsolete docs or not..
but this POT/--- file isn't appeared on the document (if you build)
do you call it obsolete? you intend not to include those docs? 

Regards,
Mie
Comment 5 Sean Flanigan 2012-11-07 19:09:31 EST
Zanata can't detect whether the POT file is still used by Publican, that's up to the project maintainer.

The document will only be obsolete, as far as Zanata is concerned, if the project maintainer deletes the POT and then pushes the source to Zanata (thus deleting/obsoleting the file in Zanata).
Comment 6 David Mason 2012-11-14 19:15:31 EST
Fixed in 2.0 and 2.1.

See: https://github.com/zanata/zanata/commit/be10565eb13ad14681f74a75eca2131939ade388
Comment 7 Ding-Yi Chen 2012-11-27 03:05:16 EST
Tested with Zanata version 2.0.3-SNAPSHOT (20121127-1451)

Project AboutFedora, version f13

If Search Scope set as "Search Both" and no translation, then search on "Fedora" returned nothing, which is incorrect.

Search Scope set as "Search Source" works normally though,

Reassigned.
Comment 8 Sean Flanigan 2012-11-27 19:34:47 EST
So "Search Both" is failing to search source documents?  I don't think commit be10565e could be the reason, but it certainly sounds broken.
Comment 9 Patrick Huang 2012-11-28 00:28:09 EST
committed into release and master:
https://github.com/zanata/zanata/commit/9c39fe883674e5e9cbcf3ea966f354ee44ad411a
Comment 10 Ding-Yi Chen 2012-11-28 19:36:24 EST
Tested with Zanata version 2.0.3-SNAPSHOT (20121128-1507)

The "Search Both" now returns duplicated docuemnts if you did the push multiple times.

For example, in AboutFedora project,
You can see the document pot/Revision_History (or Revision_History) repeat multiple times.

Reassigned.
Comment 11 Patrick Huang 2012-11-28 23:04:43 EST
fixed again in release and master:
https://github.com/zanata/zanata/commit/8196537f20974d1cd6f81771659b644c70748335
Comment 12 Ding-Yi Chen 2012-11-29 01:35:54 EST
VERIFIED with Zanata version 2.0.3-SNAPSHOT (20121129-1430)
and Zanata version 2.1-SNAPSHOT (20121129-1444)

Note You need to log in before you can comment on or make changes to this bug.