Bug 838008 - [whql][netkvm] Job of "NDISTest6.5-[1 Machine]-GenericMiniportRequirements" failed on HCK on win2012
[whql][netkvm] Job of "NDISTest6.5-[1 Machine]-GenericMiniportRequirements" f...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-06 02:08 EDT by dawu
Modified: 2014-07-11 02:39 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:39:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0441 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2013-02-20 15:48:13 EST

  None (edit)
Description dawu 2012-07-06 02:08:41 EDT
Created attachment 596578 [details]
win2012-GenericMiniportRequirements.wtl

Description of problem
 Job 1119 of "NDISTest6.5-[1 Machine]-GenericMiniportRequirements" failed on HCK on win2012

Version-Release number of selected component (if applicable):
kernel-2.6.32-278.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64
virtio-win-prewhql-0.1-29


How reproducible:
always

Steps to Reproduce:
1. Start guest with CLI:

   /usr/libexec/qemu-kvm -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win8-64-nic1.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:10:1a:06:39:01,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet1,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet1,mac=00:10:1a:06:51:02,bus=pci.0,addr=0x5,id=virtio-net-pci1 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:10:1a:16:51:03,bus=pci.0,addr=0x6 -uuid d3ee35eb-2278-48f4-b71c-85112b0a79ef -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win8-nic1,server,nowait -mon chardev=111a,mode=readline -vnc :1 -bios /usr/share/seabios/bios-pm.bin -monitor stdio

2. Run task "Run NDISTest6.5"
  
Actual results:
Job failed on HCK on win2012, please refer to the HCK logs from the attached "win2012-GenericMiniportRequirements.wtl" for details

Expected results:
Job should pass without any error

Additional info:
Comment 2 dawu 2012-07-06 02:20:38 EDT
(In reply to comment #0)

> 
> Steps to Reproduce:
> 1. Start guest with CLI:
> 
>    /usr/libexec/qemu-kvm -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic -usbdevice
> tablet -drive
> file=win8-64-nic1.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,
> rerror=stop,cache=none -device
> ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1
> -netdev
> tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,
> downscript=no -device
> virtio-net-pci,netdev=hostnet0,mac=00:10:1a:06:39:01,bus=pci.0,addr=0x4,
> id=virtio-net-pci0 -netdev
> tap,sndbuf=0,id=hostnet1,vhost=on,script=/etc/qemu-ifup-private,
> downscript=no -device
> virtio-net-pci,netdev=hostnet1,mac=00:10:1a:06:51:02,bus=pci.0,addr=0x5,
> id=virtio-net-pci1 -netdev
> tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device
> e1000,netdev=hostnet2,mac=00:10:1a:16:51:03,bus=pci.0,addr=0x6 -uuid
> d3ee35eb-2278-48f4-b71c-85112b0a79ef -rtc
> base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev
> socket,id=111a,path=/tmp/monitor-win8-nic1,server,nowait -mon
> chardev=111a,mode=readline -vnc :1 -bios /usr/share/seabios/bios-pm.bin
> -monitor stdio


Correct the CLI with 2012 guest:

/usr/libexec/qemu-kvm -m 6G -smp 4 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win2012-nic1.raw,if=none,format=raw,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:10:1a:06:49:01,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet1,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet1,mac=00:10:1a:06:49:02,bus=pci.0,addr=0x5,id=virtio-net-pci1 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:10:1a:16:49:03,bus=pci.0,addr=0x6 -uuid e178b32f-004b-4e8a-96e4-e0c3b5430638 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2012-nic1,server,nowait -mon chardev=111a,mode=readline -vnc :1 -name 2012-nic1 -bios /usr/share/seabios/bios-pm.bin -monitor stdio
Comment 5 Yang Zhao 2012-09-26 04:43:03 EDT
verify it on win2012 with virtio-win-prewhql-37
steps are based on comment0.
Actual result,the job pass with error.

Base on above,this issue has been fixed.
Comment 6 Yang Zhao 2012-09-26 04:46:42 EDT
(In reply to comment #5)
> verify it on win2012 with virtio-win-prewhql-37
> steps are based on comment0.
> Actual result,the job pass with error.
the job pass without error.
> 
> Base on above,this issue has been fixed.
Comment 7 Yan Vugenfirer 2012-09-27 08:43:32 EDT
Thanks!
Comment 8 Mike Cao 2012-09-27 22:13:21 EDT
Move to verified according to comment #5 and comment #6
Comment 9 errata-xmlrpc 2013-02-21 05:39:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html

Note You need to log in before you can comment on or make changes to this bug.