Bug 838031 - ipython-0.13.1 is available
ipython-0.13.1 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ipython (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Spura
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-06 03:15 EDT by Upstream Release Monitoring
Modified: 2012-11-16 07:56 EST (History)
4 users (show)

See Also:
Fixed In Version: ipython-0.13.1-1.fc18
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-16 07:56:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
suggested patch (406 bytes, patch)
2012-08-03 21:47 EDT, Matěj Cepl
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2012-07-06 03:15:01 EDT
Latest upstream release: 0.13
Current version in Fedora Rawhide: 0.12
URL: https://github.com/ipython/ipython/downloads

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Matěj Cepl 2012-08-03 21:47:18 EDT
Created attachment 602212 [details]
suggested patch

In order to make http://koji.fedoraproject.org/koji/buildinfo?buildID=345896 work for me, I had to add these two provides.
Comment 2 Thomas Spura 2012-08-04 12:47:29 EDT
Thanks for the patch.

There were also some broken dependencies and because there are no python2-foo packages in fedora yet, I decited to revert it for ipython too:
http://pkgs.fedoraproject.org/cgit/ipython.git/commit/?id=96cccfd89e55e8d18c3e710b3405920d81a686d7

So the new logic is:
"ipython" is provided by meta package "python-ipython", which will install ALL ipython packages by default.

This means, when you want to install only ipython-console, you need to install python-ipython-console or, when installing "ipython" you'll end up with all ipython packages execept the test package installed.

Or do you have other suggestions?
Comment 3 Matěj Cepl 2012-08-06 02:05:58 EDT
Looks good (I haven't tested it though).
Comment 4 Upstream Release Monitoring 2012-10-24 03:20:01 EDT
Latest upstream release: 0.13.1
Current version in Fedora Rawhide: 0.13
URL: https://github.com/ipython/ipython/downloads

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 5 Fedora Update System 2012-10-24 05:00:48 EDT
ipython-0.13.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ipython-0.13.1-1.fc18
Comment 6 Fedora Update System 2012-10-24 12:17:49 EDT
Package ipython-0.13.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ipython-0.13.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16805/ipython-0.13.1-1.fc18
then log in and leave karma (feedback).
Comment 7 Thomas Spura 2012-11-16 07:56:04 EST
Hmm, the update is now stable, closing manually...

Note You need to log in before you can comment on or make changes to this bug.