Bug 838053 - yum update is broken or does not work.
yum update is broken or does not work.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
: 826358 841074 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-06 06:08 EDT by Mike Otto Nahrgang
Modified: 2014-01-21 18:23 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 16:43:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Otto Nahrgang 2012-07-06 06:08:59 EDT
Description of problem:
yum update does not work 'Software-Aktualisierung' gives error

Version-Release number of selected component (if applicable):
Fedora 17

How reproducible:
Update from 16 to 17 by using the Installation DVD

Steps to Reproduce:
1. Install Fedora fc16.x86_64
2. Update Fedora fc17.x86_64 with Installation DVD 17_x64
3. Perform update or wait for 'Software-Aktualisierung'
  
Actual results:
Update does not perform

Expected results:
Update of packages

Additional info:
ERROR with transaction check vs depsolve:
mesa-dri-filesystem(x86-32) is needed by mesa-dri-drivers-8.0.3-1.fc17.i686
/usr/bin/db_stat is needed by rpm-4.9.1.3-7.fc17.x86_64
Comment 1 David Timms 2012-07-07 19:17:22 EDT
(In reply to comment #0)
> ERROR with transaction check vs depsolve:
> mesa-dri-filesystem(x86-32) is needed by mesa-dri-drivers-8.0.3-1.fc17.i686

I receive this error and yum fails, even with --skip-broken.

System was f16-64, upgraded to f17-64 via pxeboot. The system has non-fedora repos active, and since these were not upgraded during the upgrade, yum is trying to get the latest versions. There also seems to be duplicate package problems.
----
Downloading Packages:
Running Transaction Check
ERROR with transaction check vs depsolve:
mesa-dri-filesystem(x86-32) is needed by mesa-dri-drivers-8.0.3-1.fc17.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 13 pre-existing rpmdb problem(s), 'yum check' output follows:
abrt-retrace-client-2.0.7-3.fc16.x86_64 has missing requires of abrt = ('0', '2.0.7', '3.fc16')
...

When it didn't work, I yum update kern* rpm* yum*, in case any of these might have updates that resolve the above issue.

I have now yum update a* b* etc to reduce the non-upgradable package set.

Mike: do you get the same  "pre-existing rpmdb problem(s)" message ?
Comment 2 Piotr Madanecki 2012-09-13 13:33:29 EDT
To fix "/usr/bin/db_stat is needed by rpm-4.9.1.3-7.fc17.x86_64" error:

yum install libdb-utils
yum update
Comment 3 James Antill 2013-05-28 16:43:36 EDT
> ** Found 13 pre-existing rpmdb problem(s), 'yum check' output follows:

 This is the cause of the problem, fix those and yum will be happy again.
Comment 4 James Antill 2013-05-28 16:43:55 EDT
*** Bug 826358 has been marked as a duplicate of this bug. ***
Comment 5 James Antill 2013-05-28 16:44:19 EDT
*** Bug 841074 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.