Bug 838100 - [abrt] Zim-0.56-3.fc16: index.py:1520:get_all_pages_index:AssertionError: BUG: could not find path in index
[abrt] Zim-0.56-3.fc16: index.py:1520:get_all_pages_index:AssertionError: BUG...
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
: 750055 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2012-07-06 10:32 EDT by David Duncan
Modified: 2013-08-01 05:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-08-01 05:57:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 856102 None None None 2012-07-06 11:40:58 EDT

  None (edit)
Description David Duncan 2012-07-06 10:32:22 EDT
libreport version: 2.0.10
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/zim
executable:     /usr/bin/zim
kernel:         3.4.2-1.fc16.x86_64
time:           Fri 06 Jul 2012 10:29:48 AM EDT
uid:            1000
username:       dduncan

:index.py:1520:get_all_pages_index:AssertionError: BUG: could not find path in index
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/zim/plugins/tags.py", line 803, in on_open_page
:    self.treeview.select_page(path)
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageindex.py", line 675, in select_page
:    model.select_page(path) # highlight in model
:  File "/usr/lib/python2.7/site-packages/zim/plugins/tags.py", line 55, in select_page
:    for treepath in self.get_treepaths(mypath):
:  File "/usr/lib/python2.7/site-packages/zim/plugins/tags.py", line 496, in get_treepaths
:    pageindex = self.index.get_all_pages_index(p)
:  File "/usr/lib/python2.7/site-packages/zim/index.py", line 1520, in get_all_pages_index
:    assert False, 'BUG: could not find path in index'
:AssertionError: BUG: could not find path in index
:Local variables in innermost frame:
:i: 108
:cursor: <sqlite3.Cursor object at 0x1d6f490>
:path: <IndexPath: RHS-2.0:CapacityPlanning:mmit-glusterfs-2012.odp>
:self: <Index object at 0x1b607d0 (zim+index+Index at 0x1958f00)>
:row: <sqlite3.Row object at 0x1b63d10>

:Attached file, summit-glusterfs-2012.odp to page RHS-2.0:CapacityPlanning:Discussion.  
:A stub page appeared at RHS-2.0:summit-glusterfs-2012.odp
:Deleted the stub page.  
:Error occurred.
Comment 1 Robin Lee 2012-07-06 11:38:48 EDT
*** Bug 750055 has been marked as a duplicate of this bug. ***
Comment 2 Renich Bon Ciric 2012-07-18 06:58:37 EDT
It didn't crash... but it reported these

Package: Zim-0.56-3.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 David Duncan 2012-07-20 11:17:25 EDT
Renamed a subpage . 

Package: Zim-0.56-3.fc16
OS Release: Fedora release 16 (Verne)
Comment 4 aten 2012-10-13 18:16:20 EDT
tried to move subpage

Package: Zim-0.56-3.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 5 Pawel 2012-11-02 04:37:36 EDT
I tried to delete a duplicated branch of notes

Package: Zim-0.56-3.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 Fedora End Of Life 2013-07-03 23:00:36 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 9 Fedora End Of Life 2013-08-01 05:57:47 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.