Bug 838118 - Admin user is not created after running "aeolus-configure -p rhevm" but is created after running "aeolus configure"
Admin user is not created after running "aeolus-configure -p rhevm" but is cr...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Mike Orazi
Rehana
:
: 836027 839193 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-06 12:49 EDT by Ronelle Landy
Modified: 2012-12-04 10:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
aeolus-configure did not create an admin user when creating a Red Hat Enterprise Virtualization Manager (RHEV-M) provider. Admin user logins fail. This update fixes this behavior in the current version of aeolus-configure. aeolus-configure now creates an admin user when creating a RHEV-M provider.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:12:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronelle Landy 2012-07-06 12:49:58 EDT
Description of problem:

Saw this happen once so I'm logging it ....

Installing conductor on a new rhel 6.2 box and running....
>> aeolus-configure -p rhevm
did not create an admin user - ie: when I accessed conductor from the browser and logged in as admin/password I received the username/password does not match message

Running 
>> aeolus-configure 
or
>> aeolus-configure -p mock
did create an admin user

Are all profiles supposed to create an admin user?

Version-Release number of selected component (if applicable):

>> rpm -qa |grep aeolus
aeolus-conductor-doc-0.8.34-1.el6cf.noarch
aeolus-conductor-0.8.34-1.el6cf.noarch
aeolus-configure-2.5.10-1.el6cf.noarch
aeolus-conductor-daemons-0.8.34-1.el6cf.noarch
rubygem-aeolus-cli-0.3.3-2.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.8.34-1.el6cf.noarch



Steps to Reproduce:
1. Install conductor on a clean rhel 6.2 box
2. Copy over a rhevm_configure file to set up the rhevm provider
3. Run aeolus-configure -p rhevm ( no mock provider included)
4. Start condcutor and log in as admin/password
 

  
Actual results:

See that the username/password combo is not accepted.
Now Run aeolus-configure -p mock.
See that now you can log in as admin/password.

Expected results:
Running aeolus-configure with any profile should create an admin user the first time around. ( I think this is the expected behaviour - but leaving open for further comment here)

Additional info:

repos tested are included above.
Comment 1 Dave Johnson 2012-07-12 15:58:18 EDT
*** Bug 839193 has been marked as a duplicate of this bug. ***
Comment 2 Dave Johnson 2012-07-26 10:16:04 EDT
*** Bug 836027 has been marked as a duplicate of this bug. ***
Comment 3 Dave Johnson 2012-08-07 15:37:02 EDT
From my testing, this is fixed although I have a sneaking suspicousion there is a issue after you run aeolus-cleanup that we have yet to identify.
Comment 5 dgao 2012-09-25 16:52:43 EDT
[root@ibm-x3690x5-01 ~]# aeolus-cleanup 
aeolus-cleanup will delete local aeolus installations.
Are you sure you wish to proceed? [y/N]: y
notice: /Stage[main]/Aeolus::Image-factory::Disabled/Exec[remove_aeolus_templates]/returns: executed successfully
notice: /File[/var/lib/aeolus-conductor]/ensure: removed
notice: /Stage[main]/Aeolus::Conductor::Disabled/Service[conductor-delayed_job]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[main]/Aeolus::Deltacloud::Disabled/Service[deltacloud-core]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[main]/Aeolus::Image-factory::Disabled/Service[imagefactory]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[main]/Aeolus::Deltacloud::Disabled/Exec[remove_deltacloud_tmp_files]/returns: executed successfully
notice: /Stage[main]/Aeolus::Image-factory::Disabled/Exec[remove_imagefactory_tmp_files]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor::Disabled/Service[conductor-dbomatic]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[main]/Aeolus::Iwhd::Disabled/Exec[clean_iwhd]/returns: executed successfully
notice: /Stage[main]/Aeolus::Iwhd::Disabled/Service[iwhd]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[main]/Aeolus::Iwhd::Disabled/Service[mongod]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[main]/Aeolus::Conductor::Disabled/Service[aeolus-conductor]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[main]/Aeolus::Conductor::Disabled/Aeolus::Rails::Drop::Db[drop_aeolus_database]/Exec[drop_rails_database]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor::Disabled/Postgres::User[aeolus]/Exec[drop_aeolus_postgres_user]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor::Disabled/Service[httpd]/ensure: ensure changed 'running' to 'stopped'
notice: /File[/etc/rsyslog.d/aeolus.conf]/ensure: removed
notice: Finished catalog run in 16.19 seconds
[root@ibm-x3690x5-01 ~]# aeolus-configure -p rhevm
Launching aeolus configuration recipe...
notice: /Stage[main]/Aeolus::Image-factory/File[/var/tmp/imagefactory-mock]/ensure: created
notice: /File[/rsyslog]/seltype: seltype changed 'etc_runtime_t' to 'default_t'
notice: /Stage[main]/Aeolus::Conductor/Postgres::User[aeolus]/Exec[create_aeolus_postgres_user]/returns: executed successfully
notice: /File[/etc/imagefactory/rhevm.json]/ensure: defined content as '{md5}2a011f9ce4c7bc53cd24876ea44c8d3e'
notice: /File[/etc/rsyslog.d/aeolus.conf]/ensure: defined content as '{md5}2d45434a072b4f9d1518ce026b92c547'
notice: /Stage[main]/Aeolus::Conductor/Service[rsyslog]: Triggered 'refresh' from 1 events
notice: /Stage[main]/Apache/Service[httpd]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Conductor/Aeolus::Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor/Aeolus::Rails::Migrate::Db[migrate_aeolus_database]/Exec[migrate_rails_database]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor/Aeolus::Rails::Seed::Db[seed_aeolus_database]/Exec[seed_rails_database]/returns: executed successfully
notice: /File[/var/lib/aeolus-conductor]/ensure: created
notice: /File[/var/lib/aeolus-conductor/production.seed]/ensure: created
notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Destroy_temp_admins[before]/Exec[destroy_temp_admin-before]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[grant_site_admin_privs]: Triggered 'refresh' from 1 events
notice: /Stage[main]/Aeolus::Profiles::Common/Aeolus::Conductor::Temp_admin[temporary-administrative-user-448b766cf93dd3df315ec025372532756db793e975bbc774]/Exec[create_temp_admin]/returns: executed successfully
notice: /Stage[main]/Aeolus::Profiles::Common/Aeolus::Conductor::Temp_admin[temporary-administrative-user-448b766cf93dd3df315ec025372532756db793e975bbc774]/Exec[grant_temp_admin_privs]/returns: executed successfully
notice: /File[/usr/share/aeolus-conductor/config/initializers/secret_token.rb]/content: content changed '{md5}eedda52721c194bd0debfc74768530ab' to '{md5}34501633f691b2187f737be087a7fb46'
notice: the RHEV NFS export is on the correct storage domain and has type 'export' => true
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Profiles::Rhevm::Instance[default]/Aeolus::Rhevm::Validate[RHEV NFS export validation for default]/Notify[RHEV NFS export validation for default]/message: defined 'message' as 'the RHEV NFS export is on the correct storage domain and has type 'export' => true'
notice: /Stage[main]/Aeolus::Image-factory/Service[imagefactory]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Deltacloud::Core/Service[deltacloud-core]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Deltacloud::Core/Exec[deltacloud-core-startup-wait]/returns: executed successfully
notice: /File[/data]/seltype: seltype changed 'etc_runtime_t' to 'default_t'
notice: /Stage[main]/Aeolus::Iwhd/Service[mongod]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Iwhd/Service[iwhd]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Profiles::Common/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns: executed successfully
notice: /File[/mnt/rhevm-nfs]/ensure: created
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Profiles::Rhevm::Instance[default]/Mount[/mnt/rhevm-nfs]/ensure: defined 'ensure' as 'mounted'
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Profiles::Rhevm::Instance[default]/Mount[/mnt/rhevm-nfs]: Triggered 'refresh' from 1 events
notice: /Stage[main]/Aeolus::Conductor/Service[conductor-dbomatic]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Conductor/Service[conductor-delayed_job]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Conductor/Service[aeolus-conductor]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Profiles::Common/Aeolus::Conductor::Login[temporary-administrative-user-448b766cf93dd3df315ec025372532756db793e975bbc774]/Web_request[temporary-administrative-user-448b766cf93dd3df315ec025372532756db793e975bbc774-conductor-login]/post: post changed '' to 'https://localhost/conductor/user_session'
notice: /Stage[main]/Aeolus::Profiles::Common/Aeolus::Conductor::Login[temporary-administrative-user-448b766cf93dd3df315ec025372532756db793e975bbc774]/Exec[decrement_login_counter]/returns: executed successfully
notice: /Stage[main]/Aeolus::Profiles::Common/Aeolus::Conductor::Hwp[small-x86_64]/Web_request[hwp-small-x86_64]/post: post changed '' to 'https://localhost/conductor/hardware_profiles'
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Profiles::Rhevm::Instance[default]/Aeolus::Conductor::Provider[rhevm-default]/Web_request[provider-rhevm-default]/post: post changed '' to 'https://localhost/conductor/providers.xml'
notice: /Stage[main]/Aeolus::Profiles::Common/Aeolus::Conductor::Logout[temporary-administrative-user-448b766cf93dd3df315ec025372532756db793e975bbc774]/Web_request[temporary-administrative-user-448b766cf93dd3df315ec025372532756db793e975bbc774-conductor-logout]/get: get changed '' to 'https://localhost/conductor/logout'
notice: /Stage[main]/Aeolus::Profiles::Common/Aeolus::Conductor::Destroy_temp_admins[after]/Exec[destroy_temp_admin-after]/returns: executed successfully
notice: Finished catalog run in 99.67 seconds
[root@ibm-x3690x5-01 ~]# 



Post cleanup and configure, I was still able to log in as admin. Closing..
Comment 7 errata-xmlrpc 2012-12-04 10:12:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.