Bug 838125 - OpenCVConfig.cmake gives wrong OpenCV_INCLUDE_DIRS
OpenCVConfig.cmake gives wrong OpenCV_INCLUDE_DIRS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: opencv (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-06 13:39 EDT by Ben Boeckel
Modified: 2012-07-22 13:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-22 13:46:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Boeckel 2012-07-06 13:39:39 EDT
Description of problem:
The OpenCV_INSTALL_PATH is computed incorrectly. Instead of ../../../, it is using ../../ which results in include directories such as /usr/lib64/include/opencv.

Version-Release number of selected component (if applicable):
opencv-2.3.1-8.fc17.x86_64
Comment 1 Nicolas Chauvet (kwizart) 2012-07-06 13:44:26 EDT
Patch welcomed, until then please use pkgconfig opencv.pc
Please retest with opencv 2.4.1 currently in the fedora devel branch (not built yet).

Since OpenCVConfig.cmake is broken, please consider it unreliable before (at least) opencv 2.4.3
Comment 2 Honza Horak 2012-07-10 07:58:31 EDT
A patch included in opencv-2.4.2-1.fc18 should fix it, you can test the rawhide build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=329744

Note You need to log in before you can comment on or make changes to this bug.