Bug 838146 - subscription-manager CLI tool does not allow unsubscribe when not registered
subscription-manager CLI tool does not allow unsubscribe when not registered
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: William Poteat
Entitlement Bugs
: Regression
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-06 15:31 EDT by John Sefler
Modified: 2013-01-07 22:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:56:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-07-06 15:31:20 EDT
Description of problem:
Bug 735338 has re-surfaced in rhel59.


Version-Release number of selected component (if applicable):
[root@jsefler-59server ~]# rpm -q subscription-manager
subscription-manager-1.0.8-1.git.8.b51785c.el5

How reproducible:


Steps to Reproduce:
See bug 735338


Actual results:


Expected results:


Additional info:
Comment 3 Shwetha Kallesh 2012-08-07 04:37:44 EDT
Verified!!


RPM version:
[root@dhcp201-115 tmp]# rpm -qa | grep subscription-manager
subscription-manager-migration-data-1.11.2.2-1.git.2.c3c8e22.el5
subscription-manager-firstboot-1.0.12-1.git.36.cb30843.el5
subscription-manager-migration-1.0.12-1.git.36.cb30843.el5
subscription-manager-1.0.12-1.git.36.cb30843.el5
subscription-manager-gui-1.0.12-1.git.36.cb30843.el5


[root@dhcp201-115 tmp]# subscription-manager unregister
System has been un-registered.
[root@dhcp201-115 tmp]# subscription-manager import --certificate=/etc/pki/tmp/cert.pem 
Error while checking server version: No such file or directory
Successfully imported certificate cert.pem
[root@dhcp201-115 tmp]# subscription-manager list --consumed
Error while checking server version: No such file or directory
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+

Subscription Name:    	Awesome OS for x86_64
Provides:             	Awesome OS for x86_64 Bits
SKU:                  	awesomeos-x86_64
Contract:             	66
Account:              	12331131231
Serial Number:        	189743205064406490
Active:               	True
Quantity Used:        	1
Service Level:        	
Service Type:         	
Starts:               	08/06/2012
Ends:                 	08/06/2013

[root@dhcp201-115 tmp]# subscription-manager unsubscribe --serial 189743205064406490
Error while checking server version: No such file or directory
This machine has been unsubscribed from subscription with serial number 189743205064406490
Comment 5 errata-xmlrpc 2013-01-07 22:56:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.