Bug 838238 - VT6212L PCI USB 7 port card not working
VT6212L PCI USB 7 port card not working
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-07 13:35 EDT by Gavin Davenport
Modified: 2012-08-21 14:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-21 14:00:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshw listing (15.42 KB, application/octet-stream)
2012-07-07 13:35 EDT, Gavin Davenport
no flags Details
lspci output (7.51 KB, application/octet-stream)
2012-07-07 13:36 EDT, Gavin Davenport
no flags Details
lsusb output (23.00 KB, application/octet-stream)
2012-07-07 13:36 EDT, Gavin Davenport
no flags Details
dmesg (52.64 KB, application/octet-stream)
2012-07-07 13:37 EDT, Gavin Davenport
no flags Details

  None (edit)
Description Gavin Davenport 2012-07-07 13:35:41 EDT
Created attachment 596791 [details]
lshw listing

Description of problem:
Card doesn't work. Ports don't get enabled, is not reported correctly by lspci, lsusb or lshw

Version-Release number of selected component (if applicable):
3.4.2-1.fc16.i686

How reproducible:
Every time

Steps to Reproduce:
1. install card
2. Expect it to report, or at least put something in dmesg when I plug in a device.
3.
  
Actual results:
All ports for card are disabled and dont' work.

Expected results:
Ports to work.

Additional info:
Have tried 2 different cards based on this chipset.
http://intrl.startech.com/Cards-Adapters/USB-2/Card/7-Port-PCI-USB-Card-Adapter~PCIUSB7
http://www.maplin.co.uk/usb-2.0-5-port-41-pci-card-228619

System is a Sumicom S635HC
http://www.diffusion-informatique.com/kingyoung-sumicom/s635.php
http://www.kustompcs.co.uk/acatalog/info_1388.html

Would like advice on what I need to do to diagnose this.
Comment 1 Gavin Davenport 2012-07-07 13:36:27 EDT
Created attachment 596792 [details]
lspci output
Comment 2 Gavin Davenport 2012-07-07 13:36:55 EDT
Created attachment 596793 [details]
lsusb output
Comment 3 Gavin Davenport 2012-07-07 13:37:35 EDT
Created attachment 596794 [details]
dmesg
Comment 4 Gavin Davenport 2012-07-07 13:40:29 EDT
Seems that USB drivers are built into this kernel, they aren't appearing in lsmod and are not removable.

Onboard USB ports work fine.
Comment 5 Gavin Davenport 2012-07-07 13:44:26 EDT
Onboard USB reporting as:
VT82xxxxx UHCI USB 1.1 Controller
Comment 6 Gavin Davenport 2012-07-11 14:14:45 EDT
Nobody interested ? VT6212L just *doesn't* work under FC16 ?
Is there a solution I haven't found on the internet ?
Comment 7 Gavin Davenport 2012-08-21 13:59:48 EDT
Not a bug. Hardware fault.

Note You need to log in before you can comment on or make changes to this bug.