Bug 838339 - RHEVM - Admin GUI: New Quota dialog presents irrelevant storage domains
RHEVM - Admin GUI: New Quota dialog presents irrelevant storage domains
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Gilad Chaplik
Daniel Paikov
sla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-08 10:33 EDT by Daniel Paikov
Modified: 2016-02-10 15:13 EST (History)
8 users (show)

See Also:
Fixed In Version: ic12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:05:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Paikov 2012-07-08 10:33:47 EDT
Quota -> Add -> Specific Storage Domains -> the list of domains includes domains that are attached to other DCs and not the current one. These domains should be filtered out.

Also, the list includes deactivated storage domains (but not unattached domains), these domains should also maybe be filtered out.
Comment 1 Gilad Chaplik 2012-07-24 10:57:02 EDT
I cannot see other domains for different data centers (verified it with the code).

about the deactivated SD, I think we need to show them because when the SD was up, we could have set quota limitation on it, so we need to show it also when it's deactivated.
Comment 2 Gilad Chaplik 2012-07-24 11:00:28 EDT
probably fixed by latest refactoring, moving to ON_QA
Comment 3 Daniel Paikov 2012-07-29 08:18:39 EDT
Checked on si12.

Note You need to log in before you can comment on or make changes to this bug.