Bug 838355 - SELinux is preventing /usr/bin/env from 'execute' accesses on the file /etc/rc.d/init.d/boinc-client.
SELinux is preventing /usr/bin/env from 'execute' accesses on the file /etc/r...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c529238822db6d69869d682a6f9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-08 13:35 EDT by Hakan Duran
Modified: 2012-07-09 04:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 04:45:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hakan Duran 2012-07-08 13:35:28 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.4-3.fc17.x86_64
time:           Sun 08 Jul 2012 12:34:54 PM CDT

description:
:SELinux is preventing /usr/bin/env from 'execute' accesses on the file /etc/rc.d/init.d/boinc-client.
:
:*****  Plugin leaks (86.2 confidence) suggests  ******************************
:
:If you want to ignore env trying to execute access the boinc-client file, because you believe it should not need this access.
:Then you should report this as a bug.  
:You can generate a local policy module to dontaudit this access.
:Do
:# grep /usr/bin/env /var/log/audit/audit.log | audit2allow -D -M mypol
:# semodule -i mypol.pp
:
:*****  Plugin catchall (14.7 confidence) suggests  ***************************
:
:If you believe that env should be allowed execute access on the boinc-client file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep env /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:logrotate_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:etc_t:s0
:Target Objects                /etc/rc.d/init.d/boinc-client [ file ]
:Source                        env
:Source Path                   /usr/bin/env
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           coreutils-8.15-6.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-134.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.4-3.fc17.x86_64
:                              #1 SMP Tue Jun 26 20:54:56 UTC 2012 x86_64 x86_64
:Alert Count                   5
:First Seen                    Mon 11 Jun 2012 03:41:01 AM CDT
:Last Seen                     Sun 08 Jul 2012 03:34:01 AM CDT
:Local ID                      01234b28-070b-4f1d-b0f6-0a78f1bf619c
:
:Raw Audit Messages
:type=AVC msg=audit(1341736441.772:253): avc:  denied  { execute } for  pid=20006 comm="env" name="boinc-client" dev="sdb6" ino=8308 scontext=system_u:system_r:logrotate_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:etc_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1341736441.772:253): arch=x86_64 syscall=execve success=no exit=EACCES a0=7fff44fa4f1b a1=7fff44fa4aa8 a2=1d87030 a3=39a8c87060 items=0 ppid=19998 pid=20006 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=12 comm=env exe=/usr/bin/env subj=system_u:system_r:logrotate_t:s0-s0:c0.c1023 key=(null)
:
:Hash: env,logrotate_t,etc_t,file,execute
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-07-09 04:45:17 EDT
Please,
execute

# restorecon -R -v /etc/rc.d/init.d/boinc-client

Note You need to log in before you can comment on or make changes to this bug.