Bug 838356 - Some services still want systemd-udev.service, even though this was renamed to systemd-udevd.service
Some services still want systemd-udev.service, even though this was renamed t...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-08 14:13 EDT by Richard W.M. Jones
Modified: 2012-09-14 09:59 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-14 09:59:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-07-08 14:13:28 EDT
Description of problem:

Machine always boots into an emergency shell.  It seems
the problem is that some important components still
depend on systemd-udev (not systemd-udevd):

# find /usr/lib/systemd -type f | xargs grep -E 'systemd-udev[^-d]'
/usr/lib/systemd/system/fedora-wait-storage.service:Wants=systemd-udev.service systemd-udev-settle.service
/usr/lib/systemd/system/dracut-pre-udev.service:Before=systemd-udev.service dracut-pre-trigger.service
/usr/lib/systemd/system/dracut-pre-trigger.service:After=dracut-pre-udev.service systemd-udev.service
/usr/lib/systemd/system/dracut-pre-trigger.service:Wants=dracut-pre-udev.service systemd-udev.service

# rpm -qf /usr/lib/systemd/system/fedora-wait-storage.service
initscripts-9.39-1.fc18.x86_64
# rpm -qf /usr/lib/systemd/system/dracut-pre-udev.service
dracut-020-22.git20120702.fc18.x86_64

Note that dracut is one release older than the latest, but
that's because latest dracut is broken - bug 838105.  However
I'm pretty sure it was complaining about this even before
I downgraded.

Version-Release number of selected component (if applicable):

systemd-186-1.fc18.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Boot machine, it fails and drops into an emergency shell.
2. In dmesg:
[    4.088406] systemd[1]: Cannot add dependency job for unit systemd-udev.service, ignoring: Invalid argument
[    4.088452] systemd[1]: Cannot add dependency job for unit systemd-udev.service, ignoring: Invalid argument
Comment 1 Richard W.M. Jones 2012-07-08 14:15:04 EDT
OK maybe dracut one is fixed by the latest version, according
to the changelog:
http://koji.fedoraproject.org/koji/buildinfo?buildID=329329

However initscripts one is still wrong, and the machine isn't booting.
Comment 2 Richard W.M. Jones 2012-07-08 14:16:26 EDT
Actually it's not fixed even in latest dracut:

# rpm -qf /usr/lib/systemd/system/dracut-pre-udev.service
dracut-020-51.git20120706.fc18.x86_64
# grep systemd-udev /usr/lib/systemd/system/dracut-pre-udev.service
Before=systemd-udev.service dracut-pre-trigger.service
Comment 3 Richard W.M. Jones 2012-07-09 05:10:41 EDT
This seems likely to have been caused by dracut (bug 838367), so
close out this bug if it doesn't look like a real one.
Comment 4 Bill Nottingham 2012-07-09 14:50:52 EDT
The unit naming stuff in initscripts fixed in 9.38-2, anyway.
Comment 5 Lennart Poettering 2012-09-14 09:59:56 EDT
This appears to have been fixed a while back. Closing.

Note You need to log in before you can comment on or make changes to this bug.