This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 838426 - Stopped DIY/Jbossas7/jbosseap app status message is confusing
Stopped DIY/Jbossas7/jbosseap app status message is confusing
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Paul Morie
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 01:34 EDT by joycezhang
Modified: 2015-05-14 18:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-24 12:16:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joycezhang 2012-07-09 01:34:16 EDT
Description of problem:
Inappropriate message status shown after stopping the DIY app, after it's stopped, it still shows some running process like below, 
Stopped DIY app status return result:
RESULT:
Running Processes:
UID        PID  PPID  C    SZ   RSS PSR STIME TTY          TIME CMD
517      10566 10553  0  2297  1304   1 00:52 ?        00:00:00 /bin/bash -e /var/lib/stickshift/f3a31224729942e8ac2662bb1a0c7712/diy1/diy1_ctl.sh status
517      10569 10566  0  2363  1588   0 00:52 ?        00:00:00 /bin/bash -e /usr/libexec/stickshift/cartridges/diy-0.1/info/bin/app_ctl.sh status
517      10580 10569  0  3339  1060   0 00:52 ?        00:00:00 ps -FCvx -U 517

It should say it's  either stopped or inaccessible like other cartridges (jbossas7)

Version-Release number of selected component (if applicable):
rhc-0.95.8
devenv_1879

How reproducible:
Always

Steps to Reproduce:
1. Create diy app using existing domain

#rhc app create -a test -t diy-0.1 -l ***** 

2. stop this app and then check status using

#rhc app stop -a test -l ***** 

3. check status 
#rhc app status -a test -l *****

  
Actual results:
The PID info is displayed while the app is not accessed via browser.

Expected results:
The message should display like "Application 'test' is either stopped or inaccessible" which is consistent with other app essages.
The app is not available via browser.


Additional info:
Comment 1 Meng Bo 2012-07-30 06:41:01 EDT
The same behavior appears when check status for a stopped scalable jbossas/jbosseap app.
Comment 2 Paul Morie 2012-09-20 18:42:50 EDT
Recreated in diy-0.1.  Problem is that diy-0.1 app_ctl.sh simply prints the running user process for 'status'.

Recreated in scalable jbossas-7:

$ rhc app status -a jbossas -p none -l pmorie018@example.com

RESULT:
Application 'jbossas' is either stopped or inaccessible
Running Processes:
UID        PID  PPID  C    SZ   RSS PSR STIME TTY          TIME CMD
503      24393 24369  0  2298  1328   1 18:25 ?        00:00:00 /bin/bash -e /var/lib/stickshift/1535c720c3af4041818b8421460fdd9a/jbossas/jbossas_ctl.sh status
503      24396 24393  0  2365  1728   1 18:25 ?        00:00:00 /bin/bash -e /usr/libexec/stickshift/cartridges/embedded/haproxy-1.4/info/bin/app_ctl.sh status
503      24434 24396  0  3342  1056   1 18:25 ?        00:00:00 ps -FCvx -U 503
Application '3a67d76676' is either stopped or inaccessible

Recreated in scalable jbosseap-6.0:

$ rhc app status -a jbosseap -p none -l pmorie018@example.com

RESULT:
Application 'jbosseap' is either stopped or inaccessible
Running Processes:
UID        PID  PPID  C    SZ   RSS PSR STIME TTY          TIME CMD
503      19011 18987  1  2307  1200   0 18:39 ?        00:00:00 /bin/bash -e /var/lib/stickshift/75562393496e48cb9d221c53fe1ba2d5/jbosseap/jbosseap_ctl.sh status
503      19014 19011  1  2374  1596   1 18:39 ?        00:00:00 /bin/bash -e /usr/libexec/stickshift/cartridges/embedded/haproxy-1.4/info/bin/app_ctl.sh status
503      19052 19014  0  3343  1020   1 18:39 ?        00:00:00 ps -FCvx -U 503
Application '34fd44cf3d' is either stopped or inaccessible

Notice that 'stopped or inaccessible' message is printed twice - one for jboss, and one for the haproxy load balancer.
Comment 3 Paul Morie 2012-09-21 12:31:03 EDT
The nature of the DIY cart means that we can't make any assumptions on how to report status.  Showing the running user processes is the only sensible action to take.

I am continuing to look at the scalable jboss statuses.
Comment 4 Paul Morie 2012-09-24 12:16:40 EDT
The JBoss behavior is expected.  Scalable apps create two application instances, one with haproxy embedded as the load balancer.  The output of the 'status' command breaks down into:

1. JBoss (w/ HAProxy) status
2. HAProxy status
3. JBoss (w/o HAProxy) status (this is the one that has the hex name).

This is working as expected; not a bug.

Note You need to log in before you can comment on or make changes to this bug.