Bug 838434 - PRD Tracker: Automatically replace xi:includes with nested topic maps
PRD Tracker: Automatically replace xi:includes with nested topic maps
Status: CLOSED WONTFIX
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Casperson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 01:53 EDT by Dana Mison
Modified: 2014-08-04 18:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-17 17:20:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dana Mison 2012-07-09 01:53:20 EDT
Importing topics that use <xi:include>s to pull other sets of topics in need to replace these with a reference to another topic map.

This is a requirement of the Cloud Forms team migrating their documentation.
Comment 1 Matthew Casperson 2012-07-16 00:33:09 EDT
After importing the CloudForms topics, I ran through the process of converting their "Cloud Engine User Guide" into a CSP map. The end result of this can be see at http://file.bne.redhat.com/~mcaspers/Cloud_Engine_User_Guide/tmp/en-US/html-single/, which is built from CSP Map 9920.

Unfortunately this conversion process has to be largely a manual process. The CloudForms documentation was a mix of structure and content i.e. text that belonged in a topic (and indeed has to be in a topic to be used by Skynet) was quite often found in the parent XML files. I think this is an issue with the TopicTool, because it seemed that quite often images were not included in the CloudForms topics, although with some other edge cases. Converting this documentation for use with Skynet, where content is strictly seperated from structure, had to be done by hand.

What this means is that there is little point creating a tool to map <xi:include>s to injection points or CSP maps because the amount of work it would take to create such a tool would not be reflected in the amount of work that is saved in the conversion process.
Comment 2 Stephen Gordon 2012-07-16 09:18:39 EDT
(In reply to comment #1)
> Unfortunately this conversion process has to be largely a manual process.
> The CloudForms documentation was a mix of structure and content i.e. text
> that belonged in a topic (and indeed has to be in a topic to be used by
> Skynet) was quite often found in the parent XML files. I think this is an
> issue with the TopicTool, because it seemed that quite often images were not
> included in the CloudForms topics, although with some other edge cases.

It's not clear to me what the issue with Topic Tool is here, do you have an example? Topic Tool uses the same container for topics (section) and supports the use of images within them...of course if users didn't use that functionality then that's another matter ;).
Comment 3 Matthew Casperson 2013-06-17 17:20:58 EDT
Closing this as this is being taken on by Dan Macpherson.

Note You need to log in before you can comment on or make changes to this bug.