Bug 838437 - Yum update provides fedora 17 package on fedora 16 verne
Yum update provides fedora 17 package on fedora 16 verne
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ktp-contact-applet (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 01:57 EDT by bugzilla.fedora
Modified: 2012-07-09 08:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 08:59:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my kde.repo file (733 bytes, application/octet-stream)
2012-07-09 01:57 EDT, bugzilla.fedora
no flags Details

  None (edit)
Description bugzilla.fedora 2012-07-09 01:57:21 EDT
Created attachment 596996 [details]
my kde.repo file

Description of problem:
When doing a yum update on fedora 16, it wants to update ktp-contact-applet.x86_64 to ktp-contact-applet.x86_64 0:0.4.0-1.fc17.


Version-Release number of selected component (if applicable):
0:0.4.0-1.fc16

How reproducible:
Run yum update on fedora 16

Steps to Reproduce:
1.
2.
3.
  
Actual results:
# yum update
Loaded plugins: aliases, auto-update-debuginfo, langpacks, presto, refresh-packagekit, verify
Resolving Dependencies
--> Running transaction check
---> Package kernel.x86_64 0:3.4.4-4.fc16 will be installed
---> Package kernel-devel.x86_64 0:3.4.4-4.fc16 will be installed
---> Package kernel-headers.x86_64 0:3.4.2-1.fc16 will be updated
---> Package kernel-headers.x86_64 0:3.4.4-4.fc16 will be an update
---> Package kernel-tools.x86_64 0:3.4.2-1.fc16 will be updated
---> Package kernel-tools.x86_64 0:3.4.4-4.fc16 will be an update
---> Package krb5-debuginfo.x86_64 0:1.9.3-1.fc16 will be updated
---> Package krb5-debuginfo.x86_64 0:1.9.3-2.fc16 will be an update
---> Package ktp-contact-applet.x86_64 0:0.4.0-1.fc16 will be updated
---> Package ktp-contact-applet.x86_64 0:0.4.0-1.fc17 will be an update
--> Processing Dependency: plasma4(scriptengine-declarativeappletscript) for package: ktp-contact-applet-0.4.0-1.fc17.x86_64
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel.x86_64 0:3.3.7-1.fc16 will be erased
---> Package kernel-devel.x86_64 0:3.3.7-1.fc16 will be erased
---> Package ktp-contact-applet.x86_64 0:0.4.0-1.fc17 will be an update
--> Processing Dependency: plasma4(scriptengine-declarativeappletscript) for package: ktp-contact-applet-0.4.0-1.fc17.x86_64
--> Finished Dependency Resolution
Error: Package: ktp-contact-applet-0.4.0-1.fc17.x86_64 (kde)
           Requires: plasma4(scriptengine-declarativeappletscript)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
An update within the fedora 16 release.


Additional info:
When I disable the [kde] repo, the missing dependency is gone. kde.repo file is attached.

When checking the mirrors for the kde repo, I find a list of fc17 release rpms in the fedora 16 directory.
Comment 1 Rex Dieter 2012-07-09 08:59:02 EDT
Thanks, snafu on my part is now fixed.

If you happened to get any of these installed, you can run

yum distro-sync

to downgrade back to fc16 versions.

Note You need to log in before you can comment on or make changes to this bug.