Bug 838458 - Failed to hot_deploy php/perl/jbosseap applications with jenkins client embedded after upgrade
Failed to hot_deploy php/perl/jbosseap applications with jenkins client embed...
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 03:38 EDT by Jianwei Hou
Modified: 2015-05-14 18:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 16:00:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2012-07-09 03:38:33 EDT
Description of problem:
hot_deploy failed for an existing application(php/perl/jbosseap) after upgrade

Version-Release number of selected component (if applicable):
devenv-stage_221

How reproducible:
always

Steps to Reproduce:
1.create a php/perl/jbosseap application(either scalable or non-scalable) with jenkins embedded on an old instance
2.upgrade instance to latest
  yum update
3. ./rhc-admin-migrate --version 2.0.14
4.create hot_deploy marker in app's repo
  touch ./openshift/markers/hot_deploy
5.ssh into application, note down app's PID
  top -p $PID
6.git push and check output
7.check the instance again, the PID should still exist after build and deploy
  
Actual results:
the application's PID is lost after git push
check logs from jenkins web console, there was no "hot_deploy" logs.

Expected results:
the PID should still exist after build and deploy, since the application server is NOT restarted

Additional info:
hot_deploy an application without jenkins client was successful.
Comment 1 Mrunal Patel 2012-07-09 16:00:03 EDT
This is intentional, since a migration would involve changing user modifiable files. Supporting docs will be added for existing apps to be able to use this
feature.

Note You need to log in before you can comment on or make changes to this bug.