Bug 838509 - [whql][Netkvm][0x9F] BSOD happened on Job of "Plug and Play Driver Test (Certification)" with HCK for win2k8 (32/64)
[whql][Netkvm][0x9F] BSOD happened on Job of "Plug and Play Driver Test (Cert...
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
: 838508 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 06:01 EDT by dawu
Modified: 2013-09-15 07:27 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-15 07:27:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump file- win2k8-32 - Plug and Play Driver Test (45.37 MB, application/x-zip-compressed)
2013-05-28 03:01 EDT, guo jiang
no flags Details

  None (edit)
Description dawu 2012-07-09 06:01:25 EDT
Description of problem:
BSOD happened for Job 2059 of "Plug and Play Driver Test (Certification)" on HCK on win2k8-64

Version-Release number of selected component (if applicable):
kernel-2.6.32-278.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64
virtio-win-prewhql-0.1-29

How reproducible:
always

Steps to Reproduce:

 CLI:

/usr/libexec/qemu-kvm -m 6G -smp 4 -cpu cpu64-rhel6,+x2apic -usb -device usb-tablet -drive file=win2k8-64-nic1.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:10:1a:06:45:01,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet1,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet1,mac=00:10:1a:06:45:02,bus=pci.0,addr=0x5,id=virtio-net-pci1 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device rtl8139,netdev=hostnet2,mac=00:10:1a:16:45:03,bus=pci.0,addr=0x6 -uuid 49de09eb-038b-4b05-936a-338fe0c25f66 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-winxp-32-nic1,server,nowait -mon chardev=111a,mode=readline -spice port=5931,disable-ticketing -vga qxl -bios /usr/share/seabios/bios-pm.bin -monitor stdio

1. Run job 2059 of "Plug and Play Driver Test (Certification)"

2. Run sub job "Run Test"


Actual results:
BSOD happened with error code 9F.

Expected results:
Job should pass without any error.

Additional info:
Comment 1 dawu 2012-07-09 06:04:41 EDT
------------------------------------------------------------------------------- 
0: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

DRIVER_POWER_STATE_FAILURE (9f)
A driver has failed to complete a power IRP within a specific time (usually 10 minutes).
Arguments:
Arg1: 0000000000000004, The power transition timed out waiting to synchronize with the Pnp
	subsystem.
Arg2: 0000000000000258, Timeout in seconds.
Arg3: fffffa8004f6c720, The thread currently holding on to the Pnp lock.
Arg4: 0000000000000000, nt!TRIAGE_9F_PNP on Win7

Debugging Details:
------------------

Implicit thread is now fffffa80`04f6c720

DRVPOWERSTATE_SUBCODE:  4

IMAGE_NAME:  pci.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  49e024a5

MODULE_NAME: pci

FAULTING_MODULE: fffffa6000bce000 pci

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x9F

PROCESS_NAME:  System

CURRENT_IRQL:  2

STACK_TEXT:  
fffff800`02a9ba28 fffff800`01a47680 : 00000000`0000009f 00000000`00000004 00000000`00000258 fffffa80`04f6c720 : nt!KeBugCheckEx
fffff800`02a9ba30 fffff800`018709fd : 00000000`00000001 00000000`00000000 fffff800`01988cf0 00000000`00000001 : nt!PopBuildDeviceNotifyListWatchdog+0x40
fffff800`02a9ba70 fffff800`0186fe18 : fffff800`02a9bcd0 fffffa60`028fd702 fffff800`02a9bcc8 00000000`00000001 : nt!KiTimerListExpire+0x30d
fffff800`02a9bca0 fffff800`018705af : 000070f9`99781ed4 00000000`00000000 fffff800`00000001 fffff800`0198ba80 : nt!KiTimerExpiration+0x1d8
fffff800`02a9bd10 fffff800`01870ed2 : fffff800`01988680 fffff800`01988680 00000000`00000000 fffff800`0198db80 : nt!KiRetireDpcList+0x1df
fffff800`02a9bd80 fffff800`01a40860 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiIdleLoop+0x62
fffff800`02a9bdb0 00000000`fffff800 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!zzz_AsmCodeRange_End+0x4
fffff800`02a950b0 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00680000`00000000 : 0xfffff800


STACK_COMMAND:  kb

FOLLOWUP_NAME:  MachineOwner

FAILURE_BUCKET_ID:  X64_0x9F_VRF_4_netkvm_IMAGE_pci.sys

BUCKET_ID:  X64_0x9F_VRF_4_netkvm_IMAGE_pci.sys

Followup: MachineOwner
-------------------------------------------------------------------------------
Comment 4 Mike Cao 2012-07-13 02:10:12 EDT
*** Bug 838508 has been marked as a duplicate of this bug. ***
Comment 5 Mike Cao 2012-10-18 01:49:03 EDT
Yan ,Why this bug move to rhel6.5.0 ? 

Does it mean QE need to run WHQL on WLK ?

Thanks,
Mike
Comment 6 Yan Vugenfirer 2012-10-19 07:39:22 EDT
Hi Mike,

It was decided long time ago by Ronen and Dor that certification for RHEL6.4 will be done on WLK and therefore all HCK issues moved to RHEL6.5.

Best regards,
Yan.
Comment 7 Mike Cao 2013-01-04 01:04:09 EST
dengmin, pls check this bug status on latest qemu-kvm&virtio-win-prewhql&HCK as well
Comment 9 Mike Cao 2013-01-06 00:52:13 EST
FYI

Filter 227,Filter 1053 and Filter 1019 can make this job pass.

Best Regards,
Mike
Comment 11 Dmitry Fleytman 2013-04-25 04:34:26 EDT
Mike, please close the bug according to Comment #9
Comment 12 Mike Cao 2013-04-25 04:38:46 EDT
(In reply to comment #11)
> Mike, please close the bug according to Comment #9

QE Will run new cycle WHQL Test on netkvm Driver Next Week ,Will Change Bug status According to the Testing Results:

Mike
Comment 14 guo jiang 2013-05-28 02:42:47 EDT
win2k8-32 hit the same issue once when run netkvm job "NDISTest6.5-[2 Machine]-MPE_Ethernet.xml" with virtio-win-prewhql-61,BSOD happened with 9F code.

package:
 
    * kernel-2.6.32-369.el6.x86_64    
    * qemu-img-rhev-0.12.1.2-2.359.el6.x86_64
    * virtio-win-prewhql-0.1-61
    * spice-server-0.12.0-12.el6.x86_64
    * seabios-0.6.1.2-27.el6.x86_64
    * vgabios-0.6b-3.7.el6.noarch

Windbg info:
---------

0: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

DRIVER_POWER_STATE_FAILURE (9f)
A driver has failed to complete a power IRP within a specific time (usually 10 minutes).
Arguments:
Arg1: 00000004, The power transition timed out waiting to synchronize with the Pnp
	subsystem.
Arg2: 00000258, Timeout in seconds.
Arg3: 855f72d8, The thread currently holding on to the Pnp lock.
Arg4: 00000000, nt!TRIAGE_9F_PNP on Win7

Debugging Details:
------------------

Implicit thread is now 855f72d8

DRVPOWERSTATE_SUBCODE:  4

IMAGE_NAME:  pci.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  49e01a44

MODULE_NAME: pci

FAULTING_MODULE: 81e5d000 pci

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x9F

PROCESS_NAME:  System

CURRENT_IRQL:  2

STACK_TEXT:  
818fbb4c 81ae0096 0000009f 00000004 00000258 nt!KeBugCheckEx+0x1e
818fbb68 818b026b 8c97ea10 8c97ea00 1fbd36a8 nt!PopBuildDeviceNotifyListWatchdog+0x34
818fbc88 818afea1 818fbcd0 89efb002 818fbcd8 nt!KiTimerListExpire+0x367
818fbce8 818b0595 00000000 00000000 000bd267 nt!KiTimerExpiration+0x2a0
818fbd50 818ae7dd 00000000 0000000e 00000000 nt!KiRetireDpcList+0xba
818fbd54 00000000 0000000e 00000000 00000000 nt!KiIdleLoop+0x49


STACK_COMMAND:  kb

FOLLOWUP_NAME:  MachineOwner

FAILURE_BUCKET_ID:  0x9F_VRF_4_netkvm_IMAGE_pci.sys

BUCKET_ID:  0x9F_VRF_4_netkvm_IMAGE_pci.sys

Followup: MachineOwner
---------
Comment 15 guo jiang 2013-05-28 03:01:42 EDT
Created attachment 753759 [details]
dump file- win2k8-32 - Plug and Play Driver Test
Comment 16 Mike Cao 2013-06-16 22:54:42 EDT
Based on comment #14 ,re-assign this bug
Comment 18 guo jiang 2013-09-02 21:23:15 EDT
win2k8-32/64 hit this issue with virtio-win-prewhql-67.
other package version:
  kernel-2.6.32-414.el6.x86_64
  qemu-kvm-rhev-0.12.1.2-2.398.el6.x86_64
  spice-server-0.12.4-2.el6.x86_64  
  seabios-0.6.1.2-28.el6.x86_64
  vgabios-0.6b-3.7.el6.noarch
Comment 21 Yan Vugenfirer 2013-09-15 07:27:59 EDT
Windows 2008 certification will be done with WLK (https://bugzilla.redhat.com/show_bug.cgi?id=836467#c74).

Closing.

Note You need to log in before you can comment on or make changes to this bug.