Bug 838531 - virtio-win-prewhql-0.1-30 serial and balloon driver - installation failure on win7 x86 - The system cannot find the file specified
virtio-win-prewhql-0.1-30 serial and balloon driver - installation failure on...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 07:51 EDT by Alon Levy
Modified: 2014-08-04 18:09 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 09:34:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
previous driver version (131.56 KB, image/png)
2012-07-09 07:51 EDT, Alon Levy
no flags Details
explorer view of files being installed (187.14 KB, image/png)
2012-07-09 07:51 EDT, Alon Levy
no flags Details
final wizard step before install, shows authenticode is ok (153.08 KB, image/png)
2012-07-09 07:52 EDT, Alon Levy
no flags Details
failure: The system cannot find the file specified (149.55 KB, image/png)
2012-07-09 07:53 EDT, Alon Levy
no flags Details

  None (edit)
Description Alon Levy 2012-07-09 07:51:02 EDT
Created attachment 597048 [details]
previous driver version

Description of problem:
When attempting to install virtio-win-prewhql-0.1-30 () balloon and serial drivers I get the error in the fourth screenshot (attached), text says:
 The system cannot find the file specified

Perhaps it is of importance that the viostor driver installs successfully.

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-30

How reproducible:
100%

Steps to Reproduce:
1. open device manager
2. select device with already installed old driver
3. try to install new driver (either have disk or any other method)
  
Actual results:
fails to install, see attachments.

Expected results:
successfull installation.

Additional info:
see attachments
Comment 1 Alon Levy 2012-07-09 07:51:48 EDT
Created attachment 597050 [details]
explorer view of files being installed
Comment 2 Alon Levy 2012-07-09 07:52:38 EDT
Created attachment 597052 [details]
final wizard step before install, shows authenticode is ok
Comment 3 Alon Levy 2012-07-09 07:53:22 EDT
Created attachment 597053 [details]
failure: The system cannot find the file specified
Comment 5 Vadim Rozenfeld 2012-07-10 03:37:15 EDT
Mike,
Could you please try reproducing this issue?

Thank you,
Vadim.
Comment 6 Mike Cao 2012-07-10 09:46:25 EDT
(In reply to comment #5)
> Mike,
> Could you please try reproducing this issue?
> 
> Thank you,
> Vadim.

Hello Vadim

We will try balloon driver ,For serial driver ,
We installed it and run WHQL on it ,and it success .

Aley ,From the dump ,I don't think you are installing the right driver .
Pls try to install balloon and serial driver under \\Wnet\amd64 for win7 guests


Mike
Comment 7 Vadim Rozenfeld 2012-07-10 10:30:28 EDT
(In reply to comment #6)
> (In reply to comment #5)
> > Mike,
> > Could you please try reproducing this issue?
> > 
> > Thank you,
> > Vadim.
> 
> Hello Vadim
> 
> We will try balloon driver ,For serial driver ,
> We installed it and run WHQL on it ,and it success .
> 

Thanks, it's what I expected. 

> Aley ,From the dump ,I don't think you are installing the right driver .
> Pls try to install balloon and serial driver under \\Wnet\amd64 for win7
> guests
> 
> 
> Mike
Comment 8 Alon Levy 2012-07-10 10:42:42 EDT
(In reply to comment #6)
> (In reply to comment #5)
> > Mike,
> > Could you please try reproducing this issue?
> > 
> > Thank you,
> > Vadim.
> 
> Hello Vadim
> 
> We will try balloon driver ,For serial driver ,
> We installed it and run WHQL on it ,and it success .
> 
> Aley ,From the dump ,I don't think you are installing the right driver .
> Pls try to install balloon and serial driver under \\Wnet\amd64 for win7
> guests

What dump? the guest is 32 bit, not 64, why would amd64 work? I'll give it a try and report.

> 
> 
> Mike
Comment 9 Mike Cao 2012-07-10 10:56:57 EDT
(In reply to comment #8)
> (In reply to comment #6)
> > (In reply to comment #5)
> > > Mike,
> > > Could you please try reproducing this issue?
> > > 
> > > Thank you,
> > > Vadim.
> > 
> > Hello Vadim
> > 
> > We will try balloon driver ,For serial driver ,
> > We installed it and run WHQL on it ,and it success .
> > 
> > Aley ,From the dump ,I don't think you are installing the right driver .
> > Pls try to install balloon and serial driver under \\Wnet\amd64 for win7
> > guests
> 
> What dump? the guest is 32 bit, not 64, why would amd64 work? I'll give it a
> try and report.
> 

Sorry , I mean from the attachments, you were installing the drivers under Win7 directory  ,
for balloon and serial driver ,you should install driver undering
\\WXp\X86 for 32 bit guests , \\Wnet\amd64 for 64 bit guests.
Comment 11 Min Deng 2012-07-11 02:08:46 EDT
Hi Alon,
   According to the old driver screenshot I guess your older driver is virtio-win-prewhql-0.1-22,correct me if I was wrong.I installed balloon and serial driver and upgraded them to virtio-win-prewhql-0.1-30 on windows 7 32 bits OS.
   To be honest,I didn't hit the issue.The two driver were all upgraded successfully.
   Could you please double check whether your installed the two drivers via the proper folders ? refer to comment 10.
   One tips,turn on your Windows Automatic Update Service of your guest and then have a try.Any issues please let me know.

Thanks,
Min
Comment 12 Alon Levy 2012-07-11 03:02:44 EDT
(In reply to comment #9)
> (In reply to comment #8)
> > (In reply to comment #6)
> > > (In reply to comment #5)
> > > > Mike,
> > > > Could you please try reproducing this issue?
> > > > 
> > > > Thank you,
> > > > Vadim.
> > > 
> > > Hello Vadim
> > > 
> > > We will try balloon driver ,For serial driver ,
> > > We installed it and run WHQL on it ,and it success .
> > > 
> > > Aley ,From the dump ,I don't think you are installing the right driver .
> > > Pls try to install balloon and serial driver under \\Wnet\amd64 for win7
> > > guests
> > 
> > What dump? the guest is 32 bit, not 64, why would amd64 work? I'll give it a
> > try and report.
> > 
> 
> Sorry , I mean from the attachments, you were installing the drivers under
> Win7 directory  ,
> for balloon and serial driver ,you should install driver undering
> \\WXp\X86 for 32 bit guests , \\Wnet\amd64 for 64 bit guests.

No difference. I have a 32 bit guest. Installing from WXp\X86 results in exactly the same error screen.

Trying pnputil -i -a vioser.inf results in the same error message.

I didn't have automatic updates enabled, trying that now.
Comment 13 Min Deng 2012-07-11 05:28:54 EDT
(In reply to comment #12)
> (In reply to comment #9)
> > (In reply to comment #8)
> > > (In reply to comment #6)
> > > > (In reply to comment #5)
> > > > > Mike,
> > > > > Could you please try reproducing this issue?
> > > > > 
> > > > > Thank you,
> > > > > Vadim.
> > > > 
> > > > Hello Vadim
> > > > 
> > > > We will try balloon driver ,For serial driver ,
> > > > We installed it and run WHQL on it ,and it success .
> > > > 
> > > > Aley ,From the dump ,I don't think you are installing the right driver .
> > > > Pls try to install balloon and serial driver under \\Wnet\amd64 for win7
> > > > guests
> > > 
> > > What dump? the guest is 32 bit, not 64, why would amd64 work? I'll give it a
> > > try and report.
> > > 
> > 
> > Sorry , I mean from the attachments, you were installing the drivers under
> > Win7 directory  ,
> > for balloon and serial driver ,you should install driver undering
> > \\WXp\X86 for 32 bit guests , \\Wnet\amd64 for 64 bit guests.
> 
> No difference. I have a 32 bit guest. Installing from WXp\X86 results in
> exactly the same error screen.
> 
> Trying pnputil -i -a vioser.inf results in the same error message.
> 
> I didn't have automatic updates enabled, trying that now.

Hi Alon,

   I tried the bug via "pnputil -i -a balloon.inf/vioser.inf" (install old driver and upgrade new driver via this command).I still cannot reproduce the issue.So,could you please attach more detail info if possible.
  Frankly,upgrading from old driver to new driver via *prewhql* package make no sense in some degrees because we will not deliver this package to customer directly.Our developer will help to re-build a new one and this one is what our customer need.
  Thanks for yourfeedback.

Best Regards,
Min
Comment 14 Alon Levy 2012-07-11 05:35:53 EDT
Let's see the course of events:
 I reported privately to Vadim about my problem
 Vadim asked me to open a bug
 Now you tell me that I shouldn't care about this

I don't especially care about the bug - just about managing to install the new drivers, since there are bugs with the old one that I want to check if the new one fixes.

400MB+ of updates still installing in my vm, I hope to notice (and report just for completeness sake) successfull installation after that.

Alon
Comment 15 Alon Levy 2012-07-11 09:34:10 EDT
My bad: when I created the iso file from which I installed the file I forgot to set rock ridge extensions, ending up with truncated file names, specifically WdfCoInstaller01009.dll => WDFCOINS.DLL

The full error is found in c:\windows\inf\setupapi.dev.log, and it is exactly "file doesn't exist".

Sorry for the noise,
Alon

Note You need to log in before you can comment on or make changes to this bug.