Bug 838573 - xsane crashes if Creative USB webcam is connected
xsane crashes if Creative USB webcam is connected
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sane-backends (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Nils Philippsen
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 09:54 EDT by Toni Willberg
Modified: 2016-06-06 05:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-06 05:43:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toni Willberg 2012-07-09 09:54:52 EDT
Description of problem:
 xsane dumps core

Version-Release number of selected component (if applicable):
 xsane-0.997-8.el6

How reproducible:
 always

Steps to Reproduce:
1. open terminal
2. "xsane"
  
Actual results:
 dumps core

Expected results:
 starts without errors

Additional info:
 Running on Thinkpad X220.


Sorry I don't have debuginfos installed at this time:

Program received signal SIGSEGV, Segmentation fault.
0x00000035bdc0a902 in sanei_usb_init () from /usr/lib64/libsane.so.1
Missing separate debuginfos, use: debuginfo-install xsane-0.997-8.el6.x86_64
(gdb) bt
#0  0x00000035bdc0a902 in sanei_usb_init () from /usr/lib64/libsane.so.1
#1  0x00007ffff0b49cb5 in sane_xerox_mfp_init () from /usr/lib64/sane/libsane-xerox_mfp.so.1
#2  0x00000035bdc17560 in ?? () from /usr/lib64/libsane.so.1
#3  0x00000035bdc1788d in sane_dll_get_devices () from /usr/lib64/libsane.so.1
#4  0x0000000000474a35 in ?? ()
Comment 2 Toni Willberg 2012-07-09 10:01:02 EDT
with debuginfo packages installed:

#0  0x00000035bdc0a902 in sanei_usb_init () at sanei_usb.c:603
#1  0x00007ffff0b49cb5 in sane_xerox_mfp_init (version_code=0x7fffffffb89c, cb=0x4123e0) at xerox_mfp.c:949
#2  0x00000035bdc17560 in init (be=0x9289d0) at dll.c:613
#3  0x00000035bdc1788d in sane_dll_get_devices (device_list=0x69f120, local_only=0) at dll.c:1034
Comment 3 Toni Willberg 2012-07-09 10:15:17 EDT
Tested this more, crash only happens when plugged into the docking station.

###
When docked, lsusb prints:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 025: ID 17ef:100a Lenovo ThinkPad Mini Dock Plus Series 3
Bus 001 Device 004: ID 04f2:b217 Chicony Electronics Co., Ltd Lenovo Integrated Camera (0.3MP)
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 026: ID 041e:4088 Creative Technology, Ltd 
Bus 003 Device 027: ID 046d:c03e Logitech, Inc. Premium Optical Wheel Mouse (M-BT58)
Bus 003 Device 028: ID 046d:c316 Logitech, Inc. HID-Compliant Keyboard

###
Undocked the crash doesn't happen, undocked lsusb prints:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 004: ID 04f2:b217 Chicony Electronics Co., Ltd Lenovo Integrated Camera (0.3MP)
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Comment 4 Toni Willberg 2012-07-09 10:17:45 EDT
Further testing shows that the crash only occurs my Creative webcam is connected:
 Bus 003 Device 026: ID 041e:4088 Creative Technology, Ltd 

Why it crashes, I don't know how to debug further.
Comment 5 Nils Philippsen 2012-07-09 11:26:57 EDT
This crash most likely stems from the backend driver. Does "scanimage -L" crash as well?
Comment 6 Toni Willberg 2012-08-07 03:02:01 EDT
testing "scanimage -L" causes also segfault:

Program received signal SIGSEGV, Segmentation fault.
0x0000003a5640a902 in sanei_usb_init () at sanei_usb.c:603
603		      switch (dev->descriptor.bDeviceClass)
Missing separate debuginfos, use: debuginfo-install glibc-2.12-1.80.el6_3.3.x86_64 libexif-0.6.16-4.1.el6.x86_64 libgphoto2-2.4.7-4.el6.x86_64 libieee1284-0.2.11-9.el6.x86_64 libtool-ltdl-2.2.6-15.5.el6.x86_64 libv4l-0.6.3-2.el6.x86_64
(gdb) bt

#0  0x0000003a5640a902 in sanei_usb_init () at sanei_usb.c:603
#1  0x00007ffff7dd8cb5 in sane_xerox_mfp_init (version_code=0x7fffffffc33c, cb=0x405c20 <auth_callback>) at xerox_mfp.c:949
#2  0x0000003a56417560 in init (be=0x60ee20) at dll.c:613
#3  0x0000003a5641788d in sane_dll_get_devices (device_list=0x7fffffffc4d0, local_only=0) at dll.c:1034
#4  0x0000000000403baa in main (argc=2, argv=0x7fffffffe628) at scanimage.c:1771
Comment 7 RHEL Product and Program Management 2012-09-07 01:31:04 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 8 Nils Philippsen 2013-04-19 10:03:34 EDT
Sorry for dropping the ball on this.

I have an idea what happens here (libusb returns devices with unset descriptors) and will build a scratch package for you to test while I'm away on vacation.
Comment 9 Nils Philippsen 2013-04-19 11:09:02 EDT
Um, I was barking up the wrong tree. I'd need to look at the problem when it happens in order to debug this. Can you still reproduce the issue? If yes, I'd like to take a look at it on the affected machine when I return from vacation.
Comment 10 Toni Willberg 2014-06-23 08:09:40 EDT
Since Bugzilla started nagging about needinfo I'll comment that I don't have a RHEL6 laptop available to test at this time.
Comment 11 Nils Philippsen 2016-06-06 05:43:50 EDT
Closing this as CANTFIX then. Please reopen when you have a setup with which you can reproduce the issue.

Note You need to log in before you can comment on or make changes to this bug.