Bug 838581 - wallaby cluster-remove-*server error message
wallaby cluster-remove-*server error message
Status: CLOSED DUPLICATE of bug 833308
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor-cluster-resource-agent (Show other bugs)
Development
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: grid-maint-list
MRG Quality Engineering
:
Depends On: 833308
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 10:15 EDT by Martin Kudlej
Modified: 2012-07-10 13:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 13:00:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kudlej 2012-07-09 10:15:31 EDT
Description of problem:
I think this commands should return human-readable message when error raises.

$ wallaby -H xulqrxy-node01 -U guest -P guest cluster-remove-jobserver name='hasched1'
localhost password: 
fatal:  undefined method `each_index' for {}:Hash

This is bug was found during testing 833308 so there is no ~/.ccs directory and no password entered to ricci.


Version-Release number of selected component (if applicable):
condor-7.6.5-0.16.el6.x86_64
condor-aviary-7.6.5-0.16.el6.x86_64
condor-classads-7.6.5-0.16.el6.x86_64
condor-cluster-resource-agent-7.6.5-0.16.el6.x86_64
condor-qmf-7.6.5-0.16.el6.x86_64
condor-wallaby-base-db-1.22-5.el6.noarch
condor-wallaby-client-4.1.2-1.el6.noarch
condor-wallaby-tools-4.1.2-1.el6.noarch
python-condorutils-1.5-4.el6.noarch
python-qpid-0.14-8.el6.noarch
python-qpid-qmf-0.14-7.el6_2.x86_64
python-wallabyclient-4.1.2-1.el6.noarch
qpid-cpp-client-0.14-16.el6.x86_64
qpid-cpp-server-0.14-16.el6.x86_64
qpid-qmf-0.14-7.el6_2.x86_64
qpid-tools-0.14-2.el6_2.noarch
ruby-qpid-qmf-0.14-7.el6_2.x86_64
ruby-wallaby-0.12.5-10.el6.noarch
wallaby-0.12.5-10.el6.noarch
wallaby-utils-0.12.5-10.el6.noarch


How reproducible:
100%

Steps to Reproduce:
1. steps described in bug 833308
2. setup ha scheduler hasched1
3. try commands wallaby cluster-remove-*server name='hasched1'
  
Actual results:
It ends with error message which is not very informative.

Expected results:
It will ends with human readable error message.
Comment 1 Robert Rati 2012-07-10 13:00:54 EDT
This is really a part of the fix 833308

*** This bug has been marked as a duplicate of bug 833308 ***

Note You need to log in before you can comment on or make changes to this bug.