Bug 838619 - Jobs submitted by different users using the same submission name end up grouped in a single submission owned by the first user
Jobs submitted by different users using the same submission name end up group...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: cumin (Show other bugs)
2.1.2
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: grid-maint-list
MRG Quality Engineering
:
: 1035784 (view as bug list)
Depends On:
Blocks: 838623
  Show dependency treegraph
 
Reported: 2012-07-09 11:45 EDT by Trevor McKay
Modified: 2016-05-26 16:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 838623 (view as bug list)
Environment:
Last Closed: 2016-05-26 16:17:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trevor McKay 2012-07-09 11:45:26 EDT
Description of problem:

If multiple users submit jobs through QMF or Aviary and use the same submission name, the result will be a single submission that groups jobs owned by multiple users.  However, the submission will be owned by the first user to submit under that name.

(Submissions created with condor_submit will not have this issue when default submission names are used because the id should be unique.  However, a job file that sets "+Submission = name" explicitly can also suffer a collision.)

Cumin screens submissions by owner in the "Grid user" view.  This means that the submission will be visible to the user that owns the submission, but to no others.  The submission owner will see all jobs in the submission, including jobs they do not own -- conversely, the other users will not be able to see the submission at all.

In general, any tool that screens submissions by owner will have this problem if there is a collision in submission names.

This is not a regression, however with the addition of role enforcement in Cumin this will become a more visible problem.

Version-Release number of selected component (if applicable):

cumin-0.1.5192-4 (and probably all versions of Cumin since the creation of submissions)

How reproducible:

100%

Steps to Reproduce:
1. Create a cumin/condor installation with multiple cumin users.
2. Log in as one user, and sumbit a job through Cumin with a submission description of "cat"
3. Log in as the second user and submit another job with a submission description of "cat"
4. Look at the submissions visible under the "Grid user" view while logged in as each user.
  
Actual results:

The first  user will be able to see the "cat" submission, including both jobs.
The second user will not be able to see the "cat" submission at all.

Expected results:

Both users should be able to see the "cat" submission.  Additionally, each user should only see the jobs within the submission that they actually own.

Additional info:

This is most likely not just a Cumin issue.  Making this work as expected may require changes on the condor side dealing with ownership semantics of submissions or some kind of a multi-part-key naming convention for submissions.
Comment 1 Pete MacKinnon 2012-07-09 13:14:01 EDT
Submission names are immutable once attached to a job ad (at least through the RPC interfaces). The Owner attribute gets assigned later from the job queue log parsing of the attributes. This value also becomes immutable thus other owners using the same submission name are essentially attaching to the first in.
Comment 2 Tomáš Nováčik 2013-12-03 03:26:39 EST
*** Bug 1035784 has been marked as a duplicate of this bug. ***
Comment 3 Anne-Louise Tangring 2016-05-26 16:17:33 EDT
MRG-Grid is in maintenance and only customer escalations will be considered. This issue can be reopened if a customer escalation associated with it occurs.

Note You need to log in before you can comment on or make changes to this bug.