Bug 838646 - FHS guidelines
FHS guidelines
Status: CLOSED WONTFIX
Product: Fedora Documentation
Classification: Fedora
Component: software-collections-guide (Show other bugs)
devel
All Linux
high Severity high
: ---
: ---
Assigned To: Petr Kovar
Jaromir Hradilek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 13:13 EDT by Petr Kovar
Modified: 2017-12-14 05:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-14 05:35:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kovar 2012-07-09 13:13:41 EDT
http://docs.fedoraproject.org/en-US/Fedora_Contributor_Documentation/1/html/Software_Collections_Guide/sect-Default_File_System_Hierarchy.html

Update this section to reflect that the FHS should be
/opt/<vendor tag>/<application/collection>

The example shows "rh" - but that's the vendor tag for Red Hat as registered at 
the Linux Foundation. Each company or project should use their own vendor tag.
Comment 1 Petr Kovar 2012-08-10 09:33:10 EDT
Also, include rpm2scl in the doc.  See "Helper Tools" section in https://fedorahosted.org/SoftwareCollections/
Comment 2 Edith Rivero 2014-01-17 08:00:30 EST
I was about to take this bug, but then i realized that it is fixed in section 2.2. The File System Hierarchy (link) in the same 1.0 Edition of the guide. Instead of <vendor tag> it says provider. Does it need to be updated? It seems to be understandable.

http://docs.fedoraproject.org/en-US/Fedora_Contributor_Documentation/1/html/Software_Collections_Guide/sect-The_File_System_Hierarchy.html
Comment 3 Petr Kovar 2014-02-04 12:51:49 EST
(In reply to Edith Rivero from comment #2)
> I was about to take this bug, but then i realized that it is fixed in
> section 2.2. The File System Hierarchy (link) in the same 1.0 Edition of the
> guide. Instead of <vendor tag> it says provider. Does it need to be updated?
> It seems to be understandable.
> 
> http://docs.fedoraproject.org/en-US/Fedora_Contributor_Documentation/1/html/
> Software_Collections_Guide/sect-The_File_System_Hierarchy.html

Hi Edith, yes, that part of the bug has been already fixed. Though it's likely we will need to fix / rewrite it again. That depends on the final Fedora guidelines.

Thank you,
pk
Comment 4 Petr Kovar 2017-12-14 05:35:56 EST
The Software Collections Guide has been deprecated in favor of http://softwarecollections.org/.

Closing the issue here.

Note You need to log in before you can comment on or make changes to this bug.