Bug 838724 - libvirt update crashes my vm's
libvirt update crashes my vm's
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Libvirt Maintainers
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-09 19:24 EDT by Todd
Modified: 2012-07-13 04:22 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 05:27:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my domains (xml's) (6.25 KB, application/octet-stream)
2012-07-09 22:43 EDT, Todd
no flags Details

  None (edit)
Description Todd 2012-07-09 19:24:44 EDT
Hi All,

I am coming from the "Community": Scientific Linux 6.2, 64 bit.  Would one of our interpret heroes at Red hat please fix this for me?

This morning, according to /var/log/yum.log, I got an automatic (meaning unauthorized) update to libvirt: libvirt-0.9.4-23.el6.x86_64.  This unwanted update hosed my KVM virtual machines very big time.

Symptoms:

When I fired up my KVM Virtual Machine Manager (virt-manager) this morning, four of my seven virtual machines disappeared, including the one I desperately needed.

Firing up the three that remain, I get the following error message:

     Error starting domain: unsupported configuration: spice
     TLS port set in XML configuration, but TLS is disabled
     in qemu.conf 

"virsh edit" on the missing VM's, give:
   # virsh edit KVM-WinXP
   error: failed to get domain 'KVM-WinXP'
   error: Domain not found: no domain with matching name 'KVM-WinXP'

The following work around fixed my problem:

# yum downgrade libvirt  libvirt-client  libvirt-python
Loaded plugins: priorities, refresh-packagekit, security
Setting up Downgrade Process
18 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package libvirt.x86_64 0:0.9.4-23.el6 will be a downgrade
---> Package libvirt.x86_64 0:0.9.10-21.el6 will be erased
---> Package libvirt-client.x86_64 0:0.9.4-23.el6 will be a downgrade
---> Package libvirt-client.x86_64 0:0.9.10-21.el6 will be erased
---> Package libvirt-python.x86_64 0:0.9.4-23.el6 will be a downgrade
---> Package libvirt-python.x86_64 0:0.9.10-21.el6 will be erased
--> Finished Dependency Resolution 

Now to figure out how to turn off those back ground updates.  (flash-plugin updated too.  Did not want that one either.)

Many thanks,
-T
Comment 2 Dave Allan 2012-07-09 22:25:38 EDT
Hi Todd,

Thanks for your forthrightness about your distro.  :)

Please provide:

The exact sequence of events: can you set up a test system and reproduce the problem?

What version was running before and after the upgrade?

The domain XML that reproduces the problem.

What OS was running in the guest.

Dave
Comment 3 Todd 2012-07-09 22:43:07 EDT
(In reply to comment #2)
> Hi Todd,
> 
> Thanks for your forthrightness about your distro.  :)

I am an honest beggar

> 
> Please provide:
> 
> The exact sequence of events: can you set up a test system and reproduce the
> problem?

1) turned the computer on

2) /var/log/yum.log:
    Jul 09 11:18:50 Updated: libvirt-0.9.10-21.el6.x86_64

I have since turned off yum-autoupdater

> 
> What version was running before and after the upgrade?

Before: libvirt.x86_64 0:0.9.4-23.el6
After: libvirt-0.9.4-23.el6.x86_64


> 
> The domain XML that reproduces the problem.

None of the domains (VMs) would actually run.  I will tar them all up for your.  Only W8, W7 and fedora 32 would actually show in list.


> 
> What OS was running in the guest.

See the attachment

> 
> Dave
Comment 4 Todd 2012-07-09 22:43:57 EDT
Created attachment 597194 [details]
my domains (xml's)
Comment 6 Daniel Berrange 2012-07-10 05:27:47 EDT
As indicated by the error message you quoted, you have requested that SPICE listen on a TLS  port:

    <graphics type='spice' port='5905' tlsPort='5905' autoport='no' listen='127.0.0.1'>

but you have not configured TLS in /etc/libvirt/qemu.conf.  Previously this config error was not diagnosed, but now it is. Even if you did configure TLS in qemu.conf, your config is still broken because you have given the same port number for both plain & TLS ports.  If you fix your XML files in /etc/libvirt/qemu and reload libvirtd, things will work as expected.

Note You need to log in before you can comment on or make changes to this bug.