Bug 838748 - [RFE] Enable OpenEXR support in ImageMagick
[RFE] Enable OpenEXR support in ImageMagick
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ImageMagick (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: 6.5
Assigned To: Jan Horak
Desktop QE
: FutureFeature, Patch, Triaged, ZStream
Depends On:
Blocks: 789922 1059568 1060704 1060894
  Show dependency treegraph
 
Reported: 2012-07-09 21:22 EDT by Platform RFE
Modified: 2014-10-22 03:13 EDT (History)
5 users (show)

See Also:
Fixed In Version: ImageMagick-6.5.4.7-7.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-22 03:13:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Platform RFE 2012-07-09 21:22:27 EDT
** Original comment by rdassen@redhat.com **

3. What is the nature and description of the request?

Please enable OpenEXR support in ImageMagick.

Simply add an additional "BuildRequires" line to the ImageMagick spec file
before building:

"""
BuildRequires: OpenEXR-devel

"""

*NOTE: We (Red Hat) already have the OpenEXR-devel package available in our
RHEL Optional channels.*


4. Why does the customer need this? (List the business requirements here)

OpenEXR is a high dynamic-range (HDR) image file format developed by
Industrial Light & Magic for use in computer imaging applications.

OpenEXR is used by ILM on all motion pictures currently in production. The
first movies to employ OpenEXR were Harry Potter and the Sorcerers Stone,
Men in Black II, Gangs of New York, and Signs. Since then, OpenEXR has
become ILM's main image file format. 

Customer has a need for OpenEXR support since they regularly interact with
images that are in this format. We already make both ImageMagick and the
OpenEXR-devel packages available externally. It would be a boon to their
work-flow to have the pieces already put together.


5. How would the customer like to achieve this? (List the functional
requirements here)

Having access to ImageMagick with OpenEXR support included.


6. For each functional requirement listed in question 4, specify how Red Hat
and the customer can test to confirm the requirement is successfully
implemented.

* The ability to create/manipulate OpenEXR images with ImageMagick

# convert -list format | grep -i exr
      EXR  EXR       rw-   High Dynamic-range (HDR)


7. Is there already an existing RFE upstream or in Red Hat bugzilla?

No.


8. Does the customer have any specific timeline dependencies?

If a 6.2 z-stream release is possible that would be optimal.


9. Is the sales team involved in this request and do they have any
additional input?

No.


10. List any affected packages

ImageMagick


11. Would the customer be able to assist in testing this functionality if
implemented?

Yes.
Comment 3 Platform RFE 2012-07-09 21:22:31 EDT
** Original comment by notting@redhat.com **

Given that we already ship OpenEXR ... this seems pretty simple.
Comment 8 RHEL Product and Program Management 2013-10-13 20:34:33 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 14 Benjamin Tissoires 2014-01-29 16:32:15 EST
ImageMagick-6.5.4.7-7.el6 is available in brew

Note You need to log in before you can comment on or make changes to this bug.