Bug 838787 - Evolution Gui Freeze/Hung on exit (Urgent)
Evolution Gui Freeze/Hung on exit (Urgent)
Status: CLOSED DUPLICATE of bug 838845
Product: Fedora
Classification: Fedora
Component: evolution-mapi (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 02:09 EDT by Samarjit Adhikari
Modified: 2012-07-11 07:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 07:42:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
All stack traces (1.76 KB, application/x-bzip)
2012-07-10 02:09 EDT, Samarjit Adhikari
no flags Details

  None (edit)
Description Samarjit Adhikari 2012-07-10 02:09:58 EDT
Created attachment 597222 [details]
All stack traces

Description of problem:
Evolution Gui Freeze/Hung on File-->Quit. The xkill command needs to be used for killing the gui.

Version-Release number of selected component (if applicable):
Evolution 3.4.3 / Fedora 17

How reproducible:
I am not sure about exact steps of reproduction but probable steps are as follows.

Steps to Reproduce:
1. open evolution in offline mode
2. Connect it online
3. Wait for Inbox to get updated
4. After the completion of Inbox update, i switched to "Contacts"
5. Add an LDAP server configuration for searching contacts.
6. Above configuration works great.
7. Moved to 'Inbox' folder
8. Could see the message 'Storing folder 'mailbox - <username>/Inbox' at lower pane.
9. Mark evolution File-->"Work offline" followed by "Quit" in quick succession.
10. Gui freeze
  
Actual results:
Gui freeze.

Expected results:
Gui should not freeze , rather it should come out with closing everything properly.

Additional info:
Collected all pstacks for evolution.
[ixsamar@samarjit ~]$ ps -e|grep evolution
 1394 ?        00:00:00 evolution-alarm
 1424 ?        00:00:00 evolution-calen
 2114 ?        00:00:00 evolution-addre
 2217 ?        00:01:02 evolution
Comment 1 Samarjit Adhikari 2012-07-10 02:33:14 EDT
From pstack_2217 file following looks interesting.
Even after the 'dcerpc_EcDoDisconnect_r' call there is another call of 'dcerpc_binding_handle_call' looks odd to me

Thread 4 (Thread 0x7f99ae5b0700 (LWP 2683)):
#0  0x00000035012f1f83 in epoll_wait () from /usr/lib64/libc.so.6
#1  0x00007f99c90b4d59 in ?? () from /usr/lib64/libtevent.so.0
#2  0x00007f99c90b1ed0 in _tevent_loop_once () from /usr/lib64/libtevent.so.0
#3  0x00007f99c90b2fef in tevent_req_poll () from /usr/lib64/libtevent.so.0
#4  0x00007f99c970febe in dcerpc_binding_handle_call () from /usr/lib64/libdcerpc-binding.so.0
#5  0x00007f99c9c491dd in dcerpc_EcDoDisconnect_r () from /usr/lib64/libmapi-openchange.so.0
#6  0x00007f99c9b8b068 in emsmdb_disconnect () from /usr/lib64/libmapi-openchange.so.0
Comment 2 Milan Crha 2012-07-10 08:20:00 EDT
Thanks for a bug report. All the backtraces are missing all debug information, thus it shows only public symbols, instead of line numbers and such, but even with that, it seems that evolution-mapi is waiting for a response from your Exchange server on a disconnect request. I'm not sure whether evolution-mapi can do anything with this state.

There was added evolution-mapi-3.4.3-5 into updates just recently, ~ yesterday, thus I suggest to update to it. It doesn't fix exactly this issue, but it fixes other issues in the package.
Comment 3 Samarjit Adhikari 2012-07-10 20:17:52 EDT
(In reply to comment #2)
>it seems that evolution-mapi is waiting for a
> response from your Exchange server on a disconnect request. I'm not sure
> whether evolution-mapi can do anything with this state.

Yes, from the stack trace it seems that the main working thread is waiting on epoll_wait() call.But even though i waited for long 2 hrs there is no change.Server is working fine with windows MS outlook client.

I have added some more info on steps of reproduction for the BUG 838845.

>All the backtraces are missing all debug information, thus it shows only public >symbols, instead of line numbers.
As because i am not using "Automatic Bug reporting tool" could you please guide me how to collect debug info for a process "evolution" and it's dependent libraries?
Comment 4 Milan Crha 2012-07-11 02:51:21 EDT
(In reply to comment #3)
> I have added some more info on steps of reproduction for the BUG 838845.

Does it mean we'll move there with this issue, thus I can close this as a duplicate of that bug, or vice versa? Though I agree that this seems as an issue with either OpenChange or samba4. You know, I do not want to deal with the same issue in two bugs.

> As because i am not using "Automatic Bug reporting tool" could you please
> guide me how to collect debug info for a process "evolution" and it's
> dependent libraries?

with yum you can do it like this:
   $ yum --enablerepo=*debuginfo --disablerepo=updates-testing* \
       install evolution-debuginfo evolution-data-server-debuginfo \
       evolution-mapi-debuginfo
only make sure it'll pick the same versions as your binary packages are, otherwise it won't work properly.
Comment 5 Samarjit Adhikari 2012-07-11 07:42:14 EDT

*** This bug has been marked as a duplicate of bug 838845 ***

Note You need to log in before you can comment on or make changes to this bug.