Bug 838800 - The user should be logged in community page after logging in from other page.
The user should be logged in community page after logging in from other page.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 03:53 EDT by Yujie Zhang
Modified: 2015-05-14 21:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 19:43:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2012-07-10 03:53:12 EDT
Description of problem:

When I log in from home page or other console site, I still need to log in again when I go to community page. I am using integrated instance. 

Version-Release number of selected component (if applicable):

devenv_1882

How reproducible:always


Steps to Reproduce:
1.Go to openshift website and login
2.Go to community page
3.
  
Actual results:

Still need to log in on community page.

Expected results:

The user should not be requested to login again on community page.

Additional info:

This problem did not exist in last sprint when I use integrated instance, but exist in this sprint.
Comment 1 Clayton Coleman 2012-07-10 13:05:05 EDT
I think this is because INT is not yet updated.  Will investigate today.
Comment 2 Clayton Coleman 2012-07-10 17:37:11 EDT
This is a combination of issues.  First, I pushed a change to master to make it so that Drupal uses the right configuration for streamline.  You'll need to run the sync task (or launch a new devenv with the changes to redhat_settings_staging.php) and then run enable-sso.sh again.  If your system has /etc/drupal6/default/redhat_settings.php and it doesn't have the streamline host set to a domain name "streamline-proxy.ops1.rhcloud.com" it means the your devenv is out of date.

Second, you must follow the instructions in the release ticket in this comment https://engineering.redhat.com/trac/Libra/wiki/Releases/2.0.14#Comment5clayton in order to have the redhat sso module properly registered (we changed it at the beginning of this sprint)

Once you've done both of those, clear your browser cookies and then try again.  Verify that you have the correct cookie config as well.
Comment 3 Yujie Zhang 2012-07-11 05:01:35 EDT
(In reply to comment #2)
Reproduce according to your steps above, it did work now, we can log in to community after log in from console site.

Note You need to log in before you can comment on or make changes to this bug.