Bug 838826 - Caught "A system error has occurred.If the problem persists,please contect Red Hat support" error when click the confirm link twice after register.
Caught "A system error has occurred.If the problem persists,please contect Re...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Keith Shaw
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 05:02 EDT by Yujie Zhang
Modified: 2015-05-14 21:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 13:30:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2012-07-10 05:02:26 EDT
Description of problem:

If I clicked the confirm link using invalid parameter, and then click the correct confirm link, it will return "A system error....." message and if I click the confirm link the second time after I accept and login, it will also return "A system....." message.

Version-Release number of selected component (if applicable):

devenv_1882

How reproducible:always


Steps to Reproduce:
1.Go to openshift website and register a new account
2.Click the email confirm link using invalid parameter and then click the correct link
3.Click the email confirm link after confirm and login
  
Actual results:

It will return "A system error has occurred.If the problem persists,please contect Red Hat support" message.

Expected results:

It should return the correct message.

Additional info:
Comment 1 Clayton Coleman 2012-07-10 13:22:05 EDT
Getting an exception from streamline on /wapps/streamline/confirm.html (with a preused key).

Exception report</p><p><b>message</b> <u></u></p><p><b>description</b> <u>The server encountered an int
ernal error () that prevented it from fulfilling this request.</u></p><p><b>exception</b> <pre>org.spri
ngframework.web.util.NestedServletException: Request processing failed; nested exception is java.lang.N
ullPointerException
        org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:583)
        org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.java:511)
        javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
        javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
</pre></p><p><b>root cause</b> <pre>java.lang.NullPointerException
        com.redhat.www.streamline.controller.EmailConfirmationController.handleRequestInternal(EmailCon
firmationController.java:94)
        org.springframework.web.servlet.mvc.AbstractController.handleRequest(AbstractController.java:15
3)
        org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandl
erAdapter.java:48)
Comment 3 Clayton Coleman 2012-07-10 16:33:48 EDT
Moving this to streamline team.  Giving low severity and high priority to reflect the fact that it doesn't block critical path and because it's now owned by a separate team.
Comment 4 Keith Shaw 2012-07-13 13:30:57 EDT
This issue has been fixed and release to prod.  Streamline should now respond with the following json in this case: 

{"errors":["user_email_failed_confirmation","invalid_token"]}

Note You need to log in before you can comment on or make changes to this bug.