Bug 838855 - Anaconda boot option "keymap" doesn't work with boot option "console"
Anaconda boot option "keymap" doesn't work with boot option "console"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.9
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 06:11 EDT by Ľuboš Kardoš
Modified: 2016-07-31 21:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-23 16:57:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
grub.conf for reproduce bug (695 bytes, application/octet-stream)
2012-07-10 06:12 EDT, Ľuboš Kardoš
no flags Details
File anaconda.log (34.46 KB, text/x-log)
2012-07-10 06:12 EDT, Ľuboš Kardoš
no flags Details
Screenshot of asking for appropriae keyboar (70.70 KB, image/png)
2012-07-10 06:14 EDT, Ľuboš Kardoš
no flags Details

  None (edit)
Description Ľuboš Kardoš 2012-07-10 06:11:27 EDT
Description of problem:
When I use boot options "console" and "keymap" at the same time, boot option "keymap" is ignored and anaconda ask me for selecting appropriate keybord for system in stage 2.


Steps to Reproduce:
1. Boot anaconda with options "console=ttyS0,115200 keymap=us"
  
Actual results:
Anaconda ask me for selecting appropriate keybord for system in stage 2.

Expected results:
Anaconda won't ask for selecting keyboard because of using option "keymap=us".
Comment 1 Ľuboš Kardoš 2012-07-10 06:12:17 EDT
Created attachment 597276 [details]
grub.conf for reproduce bug
Comment 2 Ľuboš Kardoš 2012-07-10 06:12:59 EDT
Created attachment 597277 [details]
File anaconda.log
Comment 3 Ľuboš Kardoš 2012-07-10 06:14:13 EDT
Created attachment 597279 [details]
Screenshot of asking for appropriae keyboar
Comment 4 Jesse Keating 2012-07-11 12:00:39 EDT
The log file shows that it attempted to load the keymap, but did not like the value you fed it:

05:33:09 WARNING : requested keymap us is not valid, asking

Are you able to make it work without the console= line?  I'm not sure that really has much to do, but it's possible.
Comment 5 Ľuboš Kardoš 2012-07-13 09:24:45 EDT
Yes. If I have option "keymap=us" on boot commandline and I don't have option "console" then it works as expected and anaconda doesn't ask for keybord.
Comment 6 Jesse Keating 2012-07-13 13:56:23 EDT
Ok, then I guess we have to dig into the C code that validates the keymap value :/
Comment 9 RHEL Product and Program Management 2012-07-23 16:57:09 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.