Bug 838904 - make-debian-img.sh failed: /dev/debian/root: not found: device not cleared. Aborting. Failed to wipe start of new LV.
make-debian-img.sh failed: /dev/debian/root: not found: device not cleared. A...
Status: CLOSED WORKSFORME
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 08:04 EDT by Richard W.M. Jones
Modified: 2012-11-23 10:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 10:47:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-07-10 08:04:14 EDT
Description of problem:

make[3]: Entering directory `/home/rjones/d/libguestfs-1.18/tests/guests'
TMPDIR=../.. \
SRCDIR=. \
bash guest-aux/make-debian-img.sh
*stdin*:11: libguestfs: error: lvcreate:   /dev/debian/root: not found: device not cleared
  Aborting. Failed to wipe start of new LV.
make[3]: *** [debian.img] Error 1

Version-Release number of selected component (if applicable):

While test-building 1.18.5.

How reproducible:

Fairly reproducible in Rawhide.

Steps to Reproduce:
1. make -C tests/guests check -j1
Comment 1 Richard W.M. Jones 2012-07-10 08:06:39 EDT
Also happens in libguestfs.git.  Seems to be a problem in LVM.
Comment 2 Richard W.M. Jones 2012-07-10 08:19:01 EDT
Fixed?  Went away?  By updating LVM.
Comment 3 Richard W.M. Jones 2012-11-23 10:47:45 EST
Works for me, so closing.

Note You need to log in before you can comment on or make changes to this bug.