Bug 839006 - libvirt-qpid-0.2.22-6.el6 requires qpid-0.12 current version is qpid-0.14
libvirt-qpid-0.2.22-6.el6 requires qpid-0.12 current version is qpid-0.14
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt-qpid (Show other bugs)
6.3
All Linux
high Severity high
: rc
: ---
Assigned To: Ian Main
Shai Revivo
:
Depends On:
Blocks: 1172231 1269194
  Show dependency treegraph
 
Reported: 2012-07-10 11:48 EDT by jcpunk
Modified: 2016-08-23 15:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 15:20:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 416393 None None None Never

  None (edit)
Description jcpunk 2012-07-10 11:48:44 EDT
Description of problem:

Attempting to install libvirt-qpid on a 6.3 system with a fully updated qpid produces the following:

package: libvirt-qpid-0.2.22-6.el6.i686
  unresolved deps:
     libqpidclient.so.5
     libqpidcommon.so.5
package: libvirt-qpid-0.2.22-6.el6.x86_64
  unresolved deps:
     libqpidcommon.so.5()(64bit)
     libqpidclient.so.5()(64bit)

qpid-cpp-client-0.14-16.el6.{i686,x86_64} provides

libqpidclient.so.6  
libqpidcommon.so.6 

This prevents use of libvirt-qpid and the current version of qpid-cpp-client.

Version-Release number of selected component (if applicable):
libvirt-qpid-0.2.22-6.el6
qpid-cpp-client-0.14-16.el6


How reproducible: 100%


Steps to Reproduce:
1. update to latest qpid
2. attempt to install libvirt-qpid
3. be sad because the packages cannot be installed together
  
Actual results:
failure to install one or the other

Expected results:
the ability to continue using libvirt-qpid with the new version of qpid-cpp-client

Additional info:
Comment 2 RHEL Product and Program Management 2012-09-07 01:36:10 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 jcpunk 2012-10-01 09:22:48 EDT
With the recent qpid security errata, I'd like to point out that this leaves systems with a problematic choice.

A) don't install security errata
B) remove libvirt-qpid

These don't seem like good options.
Comment 5 Chris Williams 2016-08-23 15:20:57 EDT
When Red Hat shipped 6.8 on May 10, 2016 RHEL 6 entered Production Phase 2. 
https://access.redhat.com/support/policy/updates/errata#Production_2_Phase
That means only "Critical and Important Security errata advisories (RHSAs) and Urgent Priority Bug Fix errata advisories (RHBAs) may be released"
This BZ is now going to be closed as it does not appear to meet Phase 2 criteria. 
If this BZ is deemed critical please open a support case in the Red Hat Customer Portal and ask that this BZ be re-opened.

Note You need to log in before you can comment on or make changes to this bug.