Bug 839028 - Error while configuring new database instance
Error while configuring new database instance
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mysql-workbench (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 13:55 EDT by pgaltieri
Modified: 2012-07-12 01:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-12 01:21:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pgaltieri 2012-07-10 13:55:39 EDT
Description of problem:
I was configuring a new server instance using mysql-workbench and received the following error during the "Test Host Machine Settings" phase

Operation failed: /etc/init.d/mysqld start is invalid

Version-Release number of selected component (if applicable):
5.2.40-1.fc16

How reproducible:
It's going to happen everytime since /etc/init.d/mysqld does not exist

Steps to Reproduce:
1.Start mysql-workbench
2.Create new server instance on local host
3.Proceed through the screens until you reach the "Test Host Machine Settings" screen.  You will notice two of the check boxes will be marked with a red 'x' and the error message will be displayed below the check boxes.
  
Actual results:
Operation failed: /etc/init.d/mysqld start is invalid

Expected results:
No errors.  

Additional info:
Comment 1 Remi Collet 2012-07-10 14:26:25 EDT
During "Operating System Selection" which is your choice for "MySQL Installation type"

"Using Fedora Linux (Vendore package)" is the right choice which defines the correct command (using /sbin/service)
Comment 2 pgaltieri 2012-07-11 15:14:18 EDT
I chose Fedora Linux, which by the way, shows up as Fedora 15 rather than Fedora 16.  Also the default is Ubuntu rather than Fedora.
Comment 3 Remi Collet 2012-07-12 01:21:56 EDT
So, you haven't select the right option.

* Fedora Linux 15 use old init script
* Fedora Linux (so all version >= 16) use correct wrapper

Note You need to log in before you can comment on or make changes to this bug.