This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 839047 - Remove stale oneoff patches from SOA-P 5.3.0 build
Remove stale oneoff patches from SOA-P 5.3.0 build
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: Build Process (Show other bugs)
5.3.0 GA
Unspecified Unspecified
unspecified Severity unspecified
: CR1
: 5.3.0 GA
Assigned To: Douglas Palmer
Martin Vecera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 15:00 EDT by Douglas Palmer
Modified: 2014-10-15 13:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-15 13:25:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPAPP-6809 Major Resolved One Off Patch - JAXB elements not processed correctly when preceded by elements with xsi:nil=true 2012-07-26 08:06:15 EDT
JBoss Issue Tracker JBPAPP-6834 Major Resolved One-off patch for JBPAPP-6822 2012-07-26 08:06:19 EDT

  None (edit)
Description Douglas Palmer 2012-07-10 15:00:07 EDT
The SOA-P 5.3.0 build still contains 2 oneoff patches from SOA-P 5.2.0.
These patches are for JBPAPP-6809 and JBPAPP-6834.
Both of these fixes were included in EAP 5.1.2.

At best these patches are redundant; at worst they lose other fixes from EAP 5.1.2.
Comment 1 Suz 2012-07-16 21:06:14 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Some outdated patches from previous builds of SOA were still present. They have been replaced to preserve performance.
Comment 2 Douglas Palmer 2012-07-17 19:17:39 EDT
We don't need a technical note for this; the problem is new to 5.3.0 and is fixed in 5.3.0.
Comment 3 Douglas Palmer 2012-07-17 19:20:00 EDT
I found 2 more outdated patch jars: jbossws-native-client.jar and jbossws-native-factories.jar. Both were identical to the jars from EAP 5.1.2; so I have removed them from soa-p.
Comment 4 Ryan Zhang 2012-07-20 02:34:50 EDT
Please verify this issue on 5.3.0 CR1.
Comment 5 Robert Balent 2012-07-23 06:38:00 EDT
Verified in SOA-P 5.3.0 CR1
Comment 6 Suz 2012-07-26 00:46:17 EDT
Deleted Technical Notes Contents.

Old Contents:
Some outdated patches from previous builds of SOA were still present. They have been replaced to preserve performance.

Note You need to log in before you can comment on or make changes to this bug.