Bug 839108 - autofs-5.0.6-19 fails to start
autofs-5.0.6-19 fails to start
Status: CLOSED DUPLICATE of bug 836524
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 20:23 EDT by Charlie Wyse
Modified: 2012-07-11 21:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 21:22:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlie Wyse 2012-07-10 20:23:45 EDT
Description of problem:
autofs-5.0.6-19 does not start up.  It appears to not be able to read any maps.  If we use the autofs-5.0.6-2 package there are no issues.  So either the configuration options or file have changed between versions, or there might be a bug somewhere.

Version-Release number of selected component (if applicable):
autofs-5.0.6-19

How reproducible:
Every time.

Steps to Reproduce:
1. Install autofs-5.0.6-19
2. Watch it boot or restart autofs
  
Actual results:
autofs.service - Automounts filesystems on demand
	  Loaded: loaded (/usr/lib/systemd/system/autofs.service; disabled)
	  Active: failed (Result: timeout) since Thu, 28 Jun 2012 11:25:10 -0700; 20s ago
	 Process: 8709 ExecStart=/usr/sbin/automount ${OPTIONS} --pid-file /run/autofs.pid (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/autofs.service

Jun 28 11:23:40 lugosi.pdi.com automount[8711]: Starting automounter version 5.0.6-19.fc17, master map  -O retry=10 -DNC1="rwcdtnc...CATION}
Jun 28 11:23:40 lugosi.pdi.com automount[8711]: using kernel protocol version 5.02
Jun 28 11:23:40 lugosi.pdi.com automount[8711]: lookup(file): file map /etc/ -O retry=10 -DNC1="rwcdtnc1" -DNCA="" -DOSREL=${OSREL...eadable
Jun 28 11:23:40 lugosi.pdi.com automount[8711]: get_query_dn: lookup(ldap): failed to find query dn under search base dns
Jun 28 11:23:40 lugosi.pdi.com automount[8711]: do_bind: lookup(ldap): failed to get query dn
Jun 28 11:23:40 lugosi.pdi.com automount[8711]: get_query_dn: lookup(ldap): failed to find query dn under search base dns
Jun 28 11:23:40 lugosi.pdi.com automount[8711]: do_bind: lookup(ldap): failed to get query dn
Jun 28 11:23:40 lugosi.pdi.com automount[8711]: lookup(ldap): couldn't connect to server default
Jun 28 11:23:40 lugosi.pdi.com automount[8711]: no mounts in table



Expected results:
Jul 10 17:20:27 lugosi automount[23963]: Starting automounter version 5.0.5-40.el6, master map auto.master-rwc
Jul 10 17:20:27 lugosi automount[23963]: using kernel protocol version 5.02
Jul 10 17:20:27 lugosi automount[23963]: lookup(file): file map /etc/auto.master-rwc missing or not readable
Jul 10 17:20:27 lugosi automount[23963]: mounted indirect on /rel with timeout 300, freq 75 seconds
Jul 10 17:20:27 lugosi automount[23963]: mounted indirect on /rel/tftpboot with timeout 300, freq 75 seconds
Jul 10 17:20:27 lugosi automount[23963]: re-connected to /rel/tftpboot/top
Jul 10 17:20:27 lugosi automount[23963]: ghosting enabled
Jul 10 17:20:27 lugosi automount[23963]: re-connected to /rel/tftpboot
Jul 10 17:20:27 lugosi automount[23963]: ghosting enabled
Jul 10 17:20:27 lugosi automount[23963]: mounted indirect on /soft with timeout 300, freq 75 seconds
Jul 10 17:20:27 lugosi automount[23963]: ghosting enabled
Jul 10 17:20:27 lugosi automount[23963]: mounted indirect on /work with timeout 300, freq 75 seconds
Jul 10 17:20:27 lugosi automount[23963]: ghosting enabled
Jul 10 17:20:27 lugosi automount[23963]: mounted indirect on /studio with timeout 300, freq 75 seconds
Jul 10 17:20:27 lugosi automount[23963]: ghosting enabled
Jul 10 17:20:27 lugosi automount[23963]: mounted indirect on /home with timeout 300, freq 75 seconds
Jul 10 17:20:27 lugosi automount[23963]: re-connected to /home/cwyse
Jul 10 17:20:27 lugosi automount[23963]: ghosting enabled
Jul 10 17:20:27 lugosi automount[23963]: mounted indirect on /usr/home with timeout 300, freq 75 seconds
Jul 10 17:20:27 lugosi automount[23963]: re-connected to /usr/home/linux
Jul 10 17:20:27 lugosi automount[23963]: ghosting enabled
Jul 10 17:20:27 lugosi automount[23963]: mounted indirect on /pdi with timeout 300, freq 75 seconds
Jul 10 17:20:27 lugosi automount[23963]: ghosting enabled
Jul 10 17:20:27 lugosi automount[23963]: mounted indirect on /pam with timeout 300, freq 75 seconds
Jul 10 17:20:27 lugosi automount[23963]: ghosting enabled


Additional info:
As mentioned the configuration file stayed the same between versions.  I tried to check the changelog but didn't see anything pertaining to new configuration files.
Comment 1 Ian Kent 2012-07-10 22:15:39 EDT
(In reply to comment #0)
> 
> Jun 28 11:23:40 lugosi.pdi.com automount[8711]: Starting automounter version
> 5.0.6-19.fc17, master map  -O retry=10 -DNC1="rwcdtnc...CATION}

That's wrong.
I have a bug that says that systemd doesn't use ${OPTIONS} properly
when OTIONS contains more than a single item. The reporter found
that removing the braces made things work again. Can you give that
a try please.
Comment 2 Ian Kent 2012-07-10 22:41:58 EDT
(In reply to comment #1)
> (In reply to comment #0)
> > 
> > Jun 28 11:23:40 lugosi.pdi.com automount[8711]: Starting automounter version
> > 5.0.6-19.fc17, master map  -O retry=10 -DNC1="rwcdtnc...CATION}
> 
> That's wrong.
> I have a bug that says that systemd doesn't use ${OPTIONS} properly
> when OTIONS contains more than a single item. The reporter found
> that removing the braces made things work again. Can you give that
> a try please.

That's changing the line:
ExecStart=/usr/sbin/automount ${OPTIONS} --pid-file /run/autofs.pid
to
ExecStart=/usr/sbin/automount $OPTIONS --pid-file /run/autofs.pid
in /lib/systemd/system/autofs.service
Comment 3 Charlie Wyse 2012-07-11 17:10:00 EDT
Gave that a shot and it worked.  Thanks Ian.   Should we just close this as a duplicate of that bug?  And I track things via that bug?
Comment 4 Ian Kent 2012-07-11 21:22:06 EDT
(In reply to comment #3)
> Gave that a shot and it worked.  Thanks Ian.   Should we just close this as
> a duplicate of that bug?  And I track things via that bug?

I think so.
I haven't done anything about it yet because I think maybe it's
a systemd bug. I need to poke someone when I get a chance to
decide.

*** This bug has been marked as a duplicate of bug 836524 ***

Note You need to log in before you can comment on or make changes to this bug.