This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 839121 - rhc-admin-chk returns error message
rhc-admin-chk returns error message
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
: Regression, Triaged
: 839123 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 23:04 EDT by Jianwei Hou
Modified: 2015-05-14 22:00 EDT (History)
3 users (show)

See Also:
Fixed In Version: next ami
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 19:43:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2012-07-10 23:04:32 EDT
Description of problem:
run rhc-admin-chk on node, it returns only error messages

Version-Release number of selected component (if applicable):
on devenv_1884

How reproducible:
always

Steps to Reproduce:
1.create an application
2.ssh into node,run rhc-admin-chk command

  
Actual results:
[root@ip-10-190-42-204 ~]# rhc-admin-chk
/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/ddl.rb:196:in `validate_request': Attempted to call action get_all_gears for stickshift but it's not declared in the DDL (MCollective::DDLValidationError)
	from /usr/lib/ruby/site_ruby/1.8/mcollective/rpc/client.rb:218:in `method_missing'
	from /usr/lib/ruby/gems/1.8/gems/gearchanger-mcollective-plugin-0.0.8/lib/gearchanger-mcollective-plugin/gearchanger/mcollective_application_container_proxy.rb:1405:in `get_all_gears_impl'
	from /usr/lib/ruby/gems/1.8/gems/gearchanger-mcollective-plugin-0.0.8/lib/gearchanger-mcollective-plugin/gearchanger/mcollective_application_container_proxy.rb:874:in `rpc_exec'
	from /usr/lib/ruby/gems/1.8/gems/gearchanger-mcollective-plugin-0.0.8/lib/gearchanger-mcollective-plugin/gearchanger/mcollective_application_container_proxy.rb:1404:in `get_all_gears_impl'
	from /usr/lib/ruby/gems/1.8/gems/stickshift-controller-0.13.12/lib/stickshift-controller/lib/stickshift/application_container_proxy.rb:37:in `get_all_gears'
	from /usr/bin/rhc-admin-chk:45


Expected results:
should return check result.

Additional info:
Comment 1 Xiaoli Tian 2012-07-10 23:34:47 EDT
*** Bug 839123 has been marked as a duplicate of this bug. ***
Comment 2 Mrunal Patel 2012-07-11 12:57:38 EDT
Know the issue, fix coming shortly.
Comment 3 Mrunal Patel 2012-07-11 13:33:02 EDT
Submitted https://github.com/openshift/crankcase/pull/221
Comment 4 Jianwei Hou 2012-07-12 01:55:58 EDT
verified on dev-stage_223

steps:
1.create an application
2.ssh into node,run rhc-admin-chk command


[root@ip-10-212-182-153 ~]# rhc-admin-chk 
Success

Note You need to log in before you can comment on or make changes to this bug.